1

I can not connect to a (probably hidden) wireless network with my RPi4.

My wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=DE

network={
ssid="NAME"
scan_ssid=1
key_mgmt=WPA-EAP
etc..
}

Hovering over the wireless icon in the taskbar states wlan0: Not associated. Clicking on it says No wireless interfaces found.

I have tried some stuff I found like adding lines like auto wlan0 in /etc/interfaces or /etc/dhcpcd.conf but none of that helped.

Apart from this hidden network, there should also be some visible and unprotected public networks to connect to, but I don't see them either. This is a fresh install of Buster.

EDIT:

I tinkered a little, and now it seems to be "half" connected?? I have no internet, but iwconfig says:

wlan0 IEEE 802.11 ESSID:"NAME"
      Mode: Managed Frequency=5.26 Ghz Access Point: B4:5D....
      Bit Rate=12 Mb/s Tx-Power=31 dBm
      ...

ifconfig says:

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
       ether dc:a6:.... txqueuelen 1000 (Ethernet)
       RX packets 198 bytes 85074 (83.0 KiB)
       RX errors 0 ...

output of ip addr is:

3: wlan0 <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
   link/ether dc:a6:... brd ff:ff:ff:ff:ff:ff

EDIT2: The suggested wpa config for the network is:

network={
ssid="NAME"
key_mgmt=WPA-EAP
pairwise=CCMP TKIP
group=CCMP TKIP
eap=TTLS
phase2="auth=PAP"
anonymous_identity="anonymous@name.edu"
identity="ab1234@name.edu"
password="password"
ca_cert="/etc/ssl/certs/T-TeleSec_GlobalRoot_Class_2.pem"
altsubject_match="DNS:radius-wlan.name.edu"
}

The only things I did differently is using a passkey generated using wpa_passphrase and adding scan_ssid=1

9
  • Please edit your question and add the output of this command: ip addr. Do you find some other hotspots with sudo iw dev wlan0 scan? – Ingo Aug 23 '19 at 11:03
  • Delete that key_mgmt line, it isn't needed with most home routers/APs. You may need bssid=AP:MA:CC:AD:DR:ES (with your AP MAC address). Easiest is to unhide it, hidden networks are a waste of time and don't enhance security in any way. – Dougie Aug 23 '19 at 11:26
  • @Dougie It's not my home network, but that of my uni. – Fl.pf. Aug 23 '19 at 11:27
  • Go and ask the Network Helpdesk, they're paid to help you connect your equipment to their network. – Dougie Aug 23 '19 at 11:28
  • @Dougie Seems Fl.pf. tries to connect to an enterprise network (WPA-EAP) on his uni, not using home like Pre Shared Keys (WPA-PSK) so he can't omit that entry. – Ingo Aug 23 '19 at 11:36
2

Seems you are mixing up two authentication key management protocols. There are mainly two methods used:

WPA-PSK uses a Pre Shared Key defined with option psk= in /etc/wpa_supplicant/wpa_supplicant.conf. This is simple and therefore mostly used in home networking.

WPA-EAP means Extensible Authentication Protocol and is often used by enterprises or universities. It does not use pre shared keys. Instead it uses asymmetric key encryption with private and public key. A typical configuration you can find in /usr/share/doc/wpa_supplicant/examples/wpa_supplicant.conf at the end:

network={
    ssid="example"
    proto=RSN
    key_mgmt=WPA-EAP
    pairwise=CCMP TKIP
    group=CCMP TKIP
    eap=TLS
    identity="user@example.com"
    ca_cert="/etc/cert/ca.pem"
    client_cert="/etc/cert/user.pem"
    private_key="/etc/cert/user.prv"
    private_key_passwd="password"
    priority=1
}

I haven't used WPA-EAP yet so I'm not very familiar with it but as you can see there is a private key file defined. This file you have to get from your university and the password to enable the usage of the key file. But there are many other combinations to use WPA-EAP. It depends extremely how the organization handles it so general advises can't be given. The example configuration you have given does not contain key files. Maybe it isn't needed for this setup?

As far as I see you are trying to connect to a hidden hotspot with a pre shared key but it isn't hidden (ssid="NAME") and uses key_mgmt=WPA-EAP. Also scan_ssid=1 isn't usable in this context. Search for its meaning in /usr/share/doc/wpa_supplicant/examples/wpa_supplicant.conf.

I would say, only your university can tell you how to connect to its hotspot and can give you needed key files if required. If you had a working configuration before it should also work with Raspbian Buster on a Raspberry Pi 4B. I haven't seen any differences so far belonging to wifi.

1
  • Thank you for your info. For now, I use a work-around by using the public network of our city that uses the same routers and log in to the intranet with VPN, but that is not satisfactory, so when I have time, I will look more into it and update/accept etc – Fl.pf. Aug 26 '19 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.