1

I've been working on setting up Transmission to download to my NAS, which has a shared NTFS directory.

I'm getting an error "Error: Permission denied (/mnt/ntfs/...) enter image description here

I understand this has to do with something with permissions, but I have no idea how to fix it.

I tried to using

sudo chown -R focus:focus /mnt/ntfs/transmission

My main user on Pi is called "focus". Also tried doing same for "debian-transmission" user.

After entering it still shown that folder belongs to root.

ls -la
drwxr-xr-x 2 root root          0 Aug 25 08:55  transmission

This is what see from my W10 machine in terms of permissions, if that helps with diagnose.

enter image description here

  • 1
    Why NTFS? Linux permissions don't work on NTFS even with ntfs-3g installed. You'll need to mount it with the transmission user using uid=transmission-daemon on the mount command. – Dougie Aug 25 at 10:54
  • I tried doing same with NFS, but then transmission works fine, but my W10 machine has no rights to move around the files on the that I downloaded to the share, I have to do it manually via console, which is pain in bum with long filenames... – Powerful Cat Aug 25 at 11:16
  • 1
    Mount an NFS share on your RPi. Run samba to make that a Windows share with universal permissions defined in samba. – Dougie Aug 25 at 12:10
  • As Dougie points out, using chown on an NTFS mount won't work. The files will just be owned by whoever mounted it. – goldilocks Aug 25 at 13:06
  • @Dougie I really a potato when it comes to linux. What do you mean by running Samba? Could you link somekind of guide I could follow along? – Powerful Cat Aug 25 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.