0

I am attempting to mount a network drive. Since I am experienced with raspbian I've asked a friend that is for help, but neither him or I have managed to succeed.

I'm, using a RPi-3b+ and a ReadyNas Nv+. My ReadyNas have two shares. Both have NFS turned on and the same settings.

My code in /etc/fstab looks like this:

10.0.1.6:/c/media   /mnt/nfs   nfs   _netdev,defaults,noatime,x-systemd.automount,x-systemd.device-timeout=30,timeo=14,x-systemd.idle-timeout=1min  2 2
10.0.1.6:/USB/media2   /mnt/usb   nfs   _netdev,defaults,noatime,x-systemd.automount,x-systemd.device-timeout=30,timeo=14,x-systemd.idle-timeout=1min  2 2

Despite that my RPI just connects to the /USB/media2 which is a USB-drive connected to my ReadyNAS.

I have also tried to mount manually with:

sudo mount 10.0.1.6:/c/media /mnt/nfs

That doesn't work either.

I've read through some treads regarding similar problems without finding a solution.

Now I'm all out of ideas, so I'm hoping that someone here can help me.

  • Seems that you have a pretty good handle on fstab options, but have you tried vers=1.0 as an additional option? – bls Aug 26 at 13:31
  • What do you get from a showmount -e 10.0.1.6 command? – Dougie Aug 26 at 20:06
1

There is not very much information you have given about error- and debug-messages. Look at the journal if you can find some messages belonging to mounting network shares:

rpi ~$ journalctl --boot --pager-end

What message do you get with

rpi ~$ sudo mount 10.0.1.6:/c/media /mnt/nfs

Try with verbose output

rpi ~$ sudo mount --verbose 10.0.1.6:/c/media /mnt/nfs

If you still can't find relevant messages you can try to use debug output. But this will give you a buch of messages. This could be confusing but maybe you see some lines telling you what's going wrong:

rpi ~$ sudo LIBMOUNT_DEBUG=all mount 10.0.1.6:/c/media /mnt/nfs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.