I installed omxplayer on Raspbian Buster Lite (no Desktop, no Xserver) on an rpi3. On my previous builds when I paused a video I would get an OSD with the current runtime and time remaining. Now nothing appears. I tried pausing through dBus and terminal. Neither shows any OSD.

I'm using

omxplayer --blank "$video"

to start videos within a screen.

Videos play perfectly fine other than missing OSD.

2 Answers 2


Alternatively, install the package containing those fonts:

sudo apt install -y fonts-freefont-ttf

(Found by searching the list of font-related packages on debian.org)

Note: For earlier versions of Raspbian, the package name was different:

sudo apt install -y ttf-freefont
  • Not sure what this did yet, but now omxplayer won't play any videos it once was...
    – nimig18
    Commented Sep 5, 2021 at 20:24
  • UPDATE: May have just needed a reboot of the machine.
    – nimig18
    Commented Sep 5, 2021 at 20:30

I usually use omxplayer wrapped in a script. When I ran it naked I saw the error message "Error: Unable to open font". A little search and I found omxplayer uses these fonts for the OSD..



I downloaded the ttf from the web then..

sudo mkdir /usr/share/fonts/truetype/freefont && chmod 755 freefont sudo cp /path/to/font/ttf/files /usr/share/fonts/truetype/freefont chmod 644 /usr/share/fonts/truetype/freefont/*

then to load them without rebooting..


I restarted omxplayer and it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.