0

I am trying to issue the following command on my Rpi

sudo apt-get update

but I've the following error message

pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Err:3 http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu trusty InRelease
  Could not connect to ppa.launchpad.net:80 (91.189.95.83). - connect (113: No route to host)
Err:4 http://ppa.launchpad.net/mozillateam/thunderbird-next/ubuntu trusty InRelease
  Unable to connect to ppa.launchpad.net:http:
Err:5 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu maverick InRelease
  Unable to connect to ppa.launchpad.net:http:
Reading package lists... Done
W: Failed to fetch http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu/dists/trusty/InRelease  Could not connect to ppa.launchpad.net:80 (91.189.95.83). - connect (113: No route to host)
W: Failed to fetch http://ppa.launchpad.net/mozillateam/thunderbird-next/ubuntu/dists/trusty/InRelease  Unable to connect to ppa.launchpad.net:http:
W: Failed to fetch http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/dists/maverick/InRelease  Unable to connect to ppa.launchpad.net:http:
W: Some index files failed to download. They have been ignored, or old ones used instead.

Here's my /etc/apt/sources.list file's content:

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
deb http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu trusty main
deb-src http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu trusty main
deb http://ppa.launchpad.net/mozillateam/thunderbird-next/ubuntu trusty main
deb-src http://ppa.launchpad.net/mozillateam/thunderbird-next/ubuntu trusty main
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu maverick main
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu maverick restricted
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu maverick universe
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu maverick multiverse
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

How can I fix it ?

EDIT: OS details:

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
  • 1
    This site supports Ubuntu and official flavors of Ubuntu. Debian is neither and off-topic here - askubuntu.com/help/on-topic – guiverc Aug 27 '19 at 11:28
  • Ok thanks. I'll delete this post. – Julien B. Aug 27 '19 at 11:30
  • What operating system do you want to use? Raspbian or Ubuntu for Raspberry Pi? – Ingo Aug 27 '19 at 12:49
  • 1
    You appear to have an eclectic mix of sources - attempting to install Ubuntu binaries on Raspbian is unlikely to work – Milliways Aug 27 '19 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy