0

I am running Ubuntu 18.04 with Jakeday's surface linux kernel on a Surface Book 2.

I had a serial connection working yesterday. I had this problem on another pi zero. I researched the "failed to set dtr/rts" issue and it seems that I need to specify device platform settings or something like this. I think the pi is not reporting itself correctly to my laptop. I had used a different pi with this recently and it was having this problem. Then I switched the SD card into this pi and it was fine. Now this pi is acting up.

Also the pi behaves just great on Windows and I can use putty to get in.

Here is the output of dmesg:

[142367.770182] usb 1-1.1.3: USB disconnect, device number 11
[142368.089461] usb 1-1.1.3: new high-speed USB device number 12 using xhci_hcd
[142381.665842] usb 1-1.1.3: new high-speed USB device number 13 using xhci_hcd
[142381.790983] usb 1-1.1.3: New USB device found, idVendor=0525, idProduct=a4a7, bcdDevice= 4.19
[142381.790988] usb 1-1.1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[142381.790991] usb 1-1.1.3: Product: Gadget Serial v2.4
[142381.790994] usb 1-1.1.3: Manufacturer: Linux 4.19.66+ with 20980000.usb
[142381.796034] cdc_acm 1-1.1.3:2.0: ttyACM0: USB ACM device
[142397.562400] cdc_acm 1-1.1.3:2.0: failed to set dtr/rts
[142402.682581] cdc_acm 1-1.1.3:2.0: failed to set dtr/rts
0

On my RPi zero I've seen the same behaviour and also the dmesg output looked the same:

failed to set dtr/rts

Being desperate for a long time today I tried again step by step the list in following answer: https://raspberrypi.stackexchange.com/a/75551 and suddenly it worked. Now I'd underline number 2. and 4. from that list.

Apparently it seems that using the only the USB data cable to power and communicate with RPi causes the flow control failure. When I use USB power cord for powering the RPi and later on the data cable is attached, the driver in Ubuntu/Mint is not complaining any more and the serial communication works like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.