2

I'm trying to run a simple X app under Weston using XWayland, but I get an error. I launch Weston as follows:

$ weston-launch --modules=xwayland.so

With the command-line argument as suggested here (cf. "weston.ini"). (I've also tried creating the weston.ini as instructed, and I got the same effect.) When I open the Wayland Terminal and run $ echo $DISPLAY, it returns with :0. But when I run a simple app like /usr/bin/galculator, I get the error cannot open display: :0. Any suggestions on how I might get galculator to launch? (That is, on how I might get an X client to connect with XWayland?)

It appears that Weston is trying to make an X server available since there is a display variable, just like was stated at the XWayland page. When I do the same experiment but I do weston-launch without the modules command-line argument, echo $DISPLAY returns nothing.

Note: I am using the 2013-09-25-wheezy-raspbian.zip available here. I haven't done any installation of Weston or Wayland since they appear to be already installed on this image. Indeed, /usr/lib/weston has the xwayland.so module, along with other Weston-related code, and Weston otherwise launches just fine.

1

Weston doesn't support X yet.

You can read more about it in this Raspberry Pi forum post. Here is what Wikipedia has to say about Weston:

The Raspberry Pi Foundation are working in collaboration with Collabora to improve performance and memory consumption, but do not expect to be able to replace X11 as the default display server until later in the year.

Basically, this is the whole reason Weston hasn't been set as the default yet for the Raspberry Pi. Once X is supported, I presume that the shift will start to make Weston the default, while bugs are removed and features are added. This should happen later this year, or early next year.

  • Thank you syb0rg for taking the time to respond. I understand that XWayland isn't in anything near a final state. Likewise, [this link] (bbs.archlinux.org/viewtopic.php?pid=1319830#p1319830) indicates that XWayland can provide some functionality. X clients are connecting. So I believe that the problem I'm having is due to a configuration issue, and not fundamental issues with XWayland itself. After all, it seems like an emulated X server would, at the very very least, be able to allow an X client to connect to it. Otherwise the devs wouldn't be able to develop against it. No? – einnocent Oct 20 '13 at 19:29
  • @einnocent I couldn't find anything that said that Wayland had already been developed for the Raspberry Pi specific ARM chip. That is why the developers had to "start over". – syb0rg Oct 21 '13 at 3:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.