1

I have a pi 3 model B+ and the official raspberry Pi PSU, and the official 7” touch screen. I’m running Raspbian with all the latest updates.

I have connected the display using a USB cable as documented on the raspberrypi.org site.

When I power up I get the underpowered lightning symbol.

What’s the right way to do this? Does using the jumper cables instead of the USB pass-through cable work more efficiently? Is there any other benefit to using them besides freeing up a port?

1

I've got the power supply connected to the Raspberry and a USB from one of the four ports connected to the display. No lightning bolts with that set-up.

Before getting the TV HAT I used the jumper wires from pin#4 (5V) and pin#6 (GND) to the display. The TV HAT doesn't have pass through pins, so I switched to the USB cable.

| improve this answer | |
1

Try to use a power adapter that can deliver 5-5.8V DC with at least 3A of current. Official Pi adaptors do this without any hassle.

| improve this answer | |
  • I’m using the official Pi power adaptor : raspberrypi.org/products/raspberry-pi-universal-power-supply but it says it supplies 2.5A? – tomh Aug 31 '19 at 20:00
  • I'm not sure. I had a very similar problem when using the Pi with one of our analyser. I got myself a 3A official adaptor from Element14 and it solved our issues. – iudeen Aug 31 '19 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.