I have a setup that uses 4 USB cameras, a USB cell modem and a USB weather station. I deal with this by adding a powered USB hub. I just bought a Waveshare USB hat which looked like a tidier solution. The USB ports on the hat are not recognised although the power light comes on and the TxD diode blinks for a little while during boot.

By "not reconised" I mean if I plug a camera in to one of the 4 hat ports, it does not show up in lsusb and when I try to take a picture with fswebcam I get the "no such device" message. I am using dietpi if that matters ....

  • Your WaveShare USB HUB HAT is "two in one", actually also a USB UART HAT. The HAT uses CP2102 USB to UART driver. I have tested two types of USB UART driver (see my answer's references), but not including CP2102. You might like to confirm that even if no USB webcams are connected, lsusb should at least shown the USB UART device. Or lsusb at least show USB mouse/keyboard, if you are using it?
    – tlfong01
    Commented Sep 4, 2019 at 3:00

2 Answers 2


I will assume you have this USB hat:
usb hat
Never used it myself, but according to the wiki:

You have to attach the USB HUB HAT to a Raspberry Pi B+/2B/3B with a USB cable

Have you done that?

  • Good ole RTFM. It worked once I did that. Nexr problem was that four cameras on the hub drew too much current to work. Fixed that by powering the whole thing off the GPIO bus - 5V on pin2, gnd on pin 6.
    – Ian Boag
    Commented Sep 4, 2019 at 22:07
  • If my answer solved your problem, please mark it as correct.
    – Botspot
    Commented Sep 4, 2019 at 22:23
  • Not sure how I "mark ir as correct" - what I said "Good ole RTFM. It worked once I did that." meant that it was the right answer. The RTFM comment was because I felt a bit dumb .... Thanks.
    – Ian Boag
    Commented Sep 6, 2019 at 2:02
  • stackoverflow.com/help/someone-answers
    – Botspot
    Commented Sep 6, 2019 at 3:04

I usually from time to time, experience this "USB hub ports/device not recognized" problem whenever I upgrade to a new USB hub, powered or not powered, or a new raspbian version.

I usually solve the problem by replacing the new but "incompatible" USB hub by the old one, or by trials and errors another one from my junk box of more than 10 old hubs.

My quick and dirty conclusion is that the old/new raspbian cannot find or wrongly use a old/new USB hub driver.

Of course I am upset when I buy an expensive USB hub and find it no working ofor Rpi. But it does often happen that I can use the Rpi incompatible new USB hub for my Windows PC, but never vice versa! :(.


(1) WavewShare Rpi USB HUB HAT (USB to UART) Board


(2) Rpi3 USB Serial Port Drivers (PL2303, Hl340)?

How many serial ports are on the Pi 3?


  • OP said USB hat, not USB hub.
    – Botspot
    Commented Sep 3, 2019 at 19:05
  • @Botspot, I beg your pardon for my ignorance. I never heard of "USB hat". I need to google and I will apologize and consider deleting my answer. The WaveShare doc says it is a "USB Hub Hat“ which I perhaps wrongly assume that it is a USB Hub in the form of a HAT: (1) waveshare.com/wiki/USB_HUB_HAT,(2) hifiberry.com/blog/what-is-a-raspberry-pi-hat
    – tlfong01
    Commented Sep 4, 2019 at 0:29
  • No harm done, and I agree waveshare's word choice was misleading. In fact, I almost made the same mistake as you did! :)
    – Botspot
    Commented Sep 4, 2019 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.