1

Upon setting boot options to autologin to console in my pi zero, it still asks for the username/password after reboot. I tried following the advice of this fourm post: https://www.raspberrypi.org/forums/viewtopic.php?t=127042 but to no avail. I keep getting these warnings when booting, which I'm thinking may be related to my problem, but googling them turns up little so I'm not entirely convinced that they're not just part of the normal systemd spiel:

[    6.308696] systemd[1]: Listening on Journal Socket.
[    6.337160] systemd[1]: Mounting Kernel Debug File System...
[    6.365338] systemd[1]: Condition check resulted in Huge Pages File System being skipped.
[    8.565984] systemd[1]: Started File System Check Daemon to report status.

I tried booting from a new SD card to see if corruption was to blame but I got the same results. The image was burned through balenaEtcher on a windows machine and communication with the pi is being done over serial. I am using the latest version of raspbian as of the writing of this post.

1

I do not have a Pi Zero W but I verified the problem with Raspbian Buster Light on a Raspberry Pi 4B and can confirm that autologin enabled with sudo raspi-config does not work on the serial debug console.

The problem is that there are different services for the hdmi attached tty and the serial console. The former is managed with getty@tty1.service the latter with serial-getty@ttyS0.service, so you have to enable autologin on the right service.

Just modify the right service with:

rpi ~$ sudo systemctl edit serial-getty@ttyS0.service

In the empty editor insert these statements, save them and quit the editor:

[Service]
ExecStart=
ExecStart=-/sbin/agetty --autologin pi --keep-baud 115200,38400,9600 %I $TERM

Reboot and it should do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.