0

My NetworkManager has suddenly stopped working on my raspberry pi due to which I am unable to connect to it either via putty or http. Configuration: I run a Raspberry Pi 3B+ with Raspbian. It is also running hassio on docker. Everything was running smoothly and I have not make any changes to the Pi. I was only fiddling with my router trying to change some wifi settings and my Pi went incommunicado. When the pi boots up it gives the following error:

NetworkManager has failed to start

journalctl -xe gives the following error:

hassio systemmd[6862]: NetworkManager.service: Failed at step EXEC
spawing /usr/sbin/NetworkManager: Exec format eror


pi@hassio:/usr/sbin $ systemctl status NetworkManager.service
â NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2019-09-08 17:00:35 IST; 18min ago
     Docs: man:NetworkManager(8)
  Process: 497 ExecStart=/usr/sbin/NetworkManager --no-daemon (code=exited, status=203/EXEC)
 Main PID: 497 (code=exited, status=203/EXEC)
      CPU: 20ms

Sep 08 17:00:34 hassio systemd[1]: NetworkManager.service: Unit entered failed state.
Sep 08 17:00:34 hassio systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
Sep 08 17:00:35 hassio systemd[1]: NetworkManager.service: Service hold-off time over, scheduling restart.
Sep 08 17:00:35 hassio systemd[1]: Stopped Network Manager.
Sep 08 17:00:35 hassio systemd[1]: NetworkManager.service: Start request repeated too quickly.
Sep 08 17:00:35 hassio systemd[1]: Failed to start Network Manager.
Sep 08 17:00:35 hassio systemd[1]: NetworkManager.service: Unit entered failed state.
Sep 08 17:00:35 hassio systemd[1]: NetworkManager.service: Failed with result 'exit-code'.

pi@hassio:/usr/sbin $ journalctl --boot --unit=NetworkManager.service
-- Logs begin at Thu 2016-11-03 22:46:43 IST, end at Sun 2019-09-08 17:20:01 IST. --
Sep 08 17:00:33 hassio systemd[1]: Starting Network Manager...
Sep 08 17:00:33 hassio systemd[1]: NetworkManager.service: Main process exited, code=exited, status=203/EXEC
Sep 08 17:00:33 hassio systemd[1]: Failed to start Network Manager.
Sep 08 17:00:33 hassio systemd[1]: NetworkManager.service: Unit entered failed state.
Sep 08 17:00:33 hassio systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
Sep 08 17:00:33 hassio systemd[1]: NetworkManager.service: Service hold-off time over, scheduling restart.
Sep 08 17:00:33 hassio systemd[1]: Stopped Network Manager.
Sep 08 17:00:33 hassio systemd[1]: Starting Network Manager...
Sep 08 17:00:33 hassio systemd[1]: NetworkManager.service: Main process exited, code=exited, status=203/EXEC
Sep 08 17:00:33 hassio systemd[1]: Failed to start Network Manager.
Sep 08 17:00:33 hassio systemd[1]: NetworkManager.service: Unit entered failed state.
Sep 08 17:00:33 hassio systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
Sep 08 17:00:33 hassio systemd[1]: NetworkManager.service: Service hold-off time over, scheduling restart.
Sep 08 17:00:33 hassio systemd[1]: Stopped Network Manager.
Sep 08 17:00:33 hassio systemd[1]: Starting Network Manager...

It retries a few times and then gives up. Can somebody help me troubleshoot this please. What else would be of value to see in the configs?

  • Exec format error means that file is not executable. Does it have the executable permission set, what do you see from file /usr/sbin/NetworkManager, and if it's a script does the text look sane? – jdonald Sep 7 at 19:54
  • 2
    Raspbian DOES NOT use Network Manager so you need to explain why and what you did – Milliways Sep 7 at 23:01
  • Please edit your question and add the uncrippled output of these commands to it: systemctl status NetworkManager.service and journalctl --boot --unit=NetworkManager.service – Ingo Sep 8 at 10:05
  • @Ingo , I have put the info you asked for. – Vijay Sharma Sep 8 at 11:53
  • 1
    "I have not make any changes to the Pi" -> Clearly you did, since as Milliways points out Raspbian does not use NetworkManager by default. If you have enabled it, you should probably disable dhcpcd. – goldilocks Sep 8 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.