2

My question is about a problem of full scale output with the Waveshare ADDA ADS1256 card.

I use the Waveshare High-Precision AD/DA Board based on ADS1256 on a Raspberry Pi 3b and the Python3 examples. I have tried 3 different examples in Python that I have found on Github : https://github.com/ul-gh/PiPyADC;

https://github.com/SeanDHeath/PyADS1256;

https://github.com/waveshare/High-Precision-AD-DA-Board

All of these 3 examples work fine but the best, in my advice, which is easy to implement in my programs in Python and the fastest in data acquisition, is the one advised by Waveshare which can be found on :

https://github.com/waveshare/High-Precision-AD-DA-Board

However, I have a problem with the digital output only with this last example. While I have no problems with the 2 other examples to obtain a full digital output scale of about 5V when I applied an analog input of about 5V (I use a 5V Vref and my sensors full scale is about 5V), with this example the output seems to be limited to about 3.8V. The effective full scale is then 0-3.8V... I specify that it is not a problem of gain because the values measured below this "limit" of 3.8V are corrects and correspond to the voltage input. It seems to be like a limitation or a saturation to 3.8V... Of course, I have tested all the signals, jumpers, configuration, ... Anyway, the 2 other Python examples work fine... So, the problem seems to be in this Python programs example.

I have tried several changes in the config.py file, without any success. I didn't find where there is a limitation or something in the python files.

Thanks a lot if someone can help me to solve this problem. Best regards,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.