0

I'm using usbboot/rpiboot with Raspberry Pi 0.

Usually when I try to discover device the device is found without a problem and the booting process succeeds, recently I upgraded the firmware (bootcode.bin, start_x.elf, etc. and the kernel using rpi-update).

Since it's impossible to do this with a device booting from NFS I had to do this in 2 stages:

  1. Running rpi-update internally.
  2. Upgrading the rest of the firmware manually (it's called msd in usbboot).

My setting is the following:

  • A PC connected to 6 different Rpi0.
  • 6 different NFS directories for booting each one of them.
  • A single msd directory with the required overlays (one for each Rpi0 according to the USB path).
  • One of the overlays and NFS base system is different from the others.

What's wrong?

When trying to push the boot firmware via USB I'm getting a Failed to claim interface error message which affects the Rpi0 with the upgraded firmware and another one which is the next in line and I can't reach it until the upgraded one is booted (the loop fails on this one and tried to boot it without looking for other devices).

What I tried so far

I tried researching what does "claim interface" means and what kernel functions are used, I've reached some conclusions that didn't help me with determining what may the cause be or what has claimed/locked the device previously.

Any suggestions?

0

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware."

sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode.

  • Will it work in usbboot mode? BTW, we had a reason, some symbols are missing from the firmware leaving our raspivid in an unusable state. – Yaron Sep 10 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.