2

Recently, some videos on Youtube will not play on XBMC on my Pi running Arch Linux. The thumbnail from the video comes up and the audio plays, but the video does not.

This happens consistently: some videos never work, while some videos always work fine.

My XBMC log contains the errors below, which some googling tells me may suggest I need codec licences.

NOTICE: COMXPlayer: Opening: http://r7---sn-cn3tc-ajts.c.youtube.com/videoplayback?sver=3&cp=U0hXR1lNUF9FUENON19RR1RKOjRlNE8xdjl0T1Z1&fexp=919113,922217,916612,930901,902550,924616,924610,907231&expire=1382922906&ms=au&id=dd84780ac798f699&itag=43&mv=m&ratebypass=yes&ipbits=8&sparams=cp,id,ip,ipbits,itag,ratebypass,source,upn,expire&source=youtube&upn=ftXw2jFiQa8&mt=1382898074&key=yt5&ip=151.229.162.58&signature=C273BDAC27EE6921F45B4BB32BFB0B838ACA1B38.1BF0003D6D40090A97FD8D2DDB8F14D094888DDA|User-Agent=Mozilla%2F5.0+%28Windows+NT+6.2%3B+Win64%3B+x64%3B+rv%3A16.0.1%29+Gecko%2F20121011+Firefox%2F16.0.1
18:23:23 T:3036131328 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:23:24 T:2798646336  NOTICE: Thread COMXPlayer start, auto delete: false
18:23:24 T:2798646336  NOTICE: Creating InputStream
18:23:24 T:2798646336  NOTICE: Creating Demuxer
18:23:24 T:2932823104  NOTICE: Thread CFileCache start, auto delete: false
18:23:24 T:2798646336  NOTICE: Opening video stream: 0 source: 256
18:23:25 T:2962224192   ERROR: COMXCoreComponent::DecoderEventHandler OMX.broadcom.video_decode - OMX_ErrorUnsupportedSetting, unsupported setting
18:23:25 T:2798646336   ERROR: COMXCoreComponent::AllocInputBuffers component(OMX.broadcom.video_decode) - OMX_UseBuffer failed with omx_err(0x80001018)
18:23:25 T:2798646336   ERROR: COMXVideo::Open AllocOMXInputBuffers error (080001018)
18:23:25 T:2798646336   ERROR: OMXPlayerVideo : Error open video output
18:23:25 T:2798646336  NOTICE: OMXClock using video as reference
18:23:25 T:2798646336 WARNING: OpenVideoStream - Unsupported stream 0. Stream disabled.
18:23:25 T:2798646336  NOTICE: Opening audio stream: 1 source: 256
18:23:25 T:2798646336  NOTICE: Creating audio thread

What could be causing this?

Note that I am using a 512MB Pi and I have tried various GPU memory splits: 128, 256, 316.

3

I had the same problem. Setting the max. video quality in the youtube settings to "ask" worked for me.

2

Exactly a year later (to the day!) after my last comment, I have found the actual solution, rather than a workaround.

Assuming you have start_x.elf in your /boot, simply place start_x=1 in your /boot/config.txt file.

This allows your the Pi to use some additional codecs which aren't otherwise picked up. Note that these are software-based so they may be slow. This is preconfigured with packages such as xbian/raspbmc, but needs to be added manually with manual installations of the OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.