0

I have 3 RPi 3B+, all exhibit the same behaviour. 2 were bought a while ago, one more recently.

When starting, on lucky days, they will get an IP from DHCP. If not lucky or upon first reboot, they no longer get an IP. Using ifconfig eth0 up to set a fixed IP succeeds, but still no network access. I ping to/from them, but network sniffing shows nothing. I've connected them directly to another machine, to bypass the switch, no difference.

I'm using the latest Raspbian image (2019-07-10), just put it on SD card and boot (and enable SSH).

If I disconnect an RPi3B+, put instead a 2B and put the same SD card in the 2B, works like a charm.

I've tried some 2.4A USB power supply. I'm otherwise using a voltage regulator, hooked its output to oscilloscope and checked, I'm getting Vavg = 5.01V, Vmin = 4.93V, Vmax = 5.05V. No dipping, so I'm pretty sure it's not a power issue (this regulator is rated 3A @ 5V).

Any suggestion?


Edit:

I get the yellow LED lit, and it blinks when I try pinging. All my equipment is 1GB compatible. Sometimes on boot up I get DHCP request packets, most times, nothing. Getting DHCP packet does not necessarily result in getting an IP, but then, setting up a fixed IP allows communication. When communication doesn't work, using dhclient doesn't cause any packet to be intercepted by network sniffer.

  • There is a significant difference between the Ethernet interfaces - the Pi3+ has Gigabit Ethernet – Milliways Sep 11 at 10:54
  • Thanks for pointing it out, I added details to my question. – user1532080 Sep 11 at 11:02
  • When you say "no difference", does it mean that the RPi sometimes gets a DHCP lease from that "another machine"? – Dmitry Grigoryev Sep 11 at 11:22
  • No, there's no DHCP on that network. I set a static IP and the 2 machines can't communicate. No traffic arrives on the interface of "that other machine" (tcpdump -i eth1... no output). So having or not a DHCP would make no difference, prior to setting the IP, I see no incoming packets. – user1532080 Sep 11 at 11:25
  • try upping the voltage from your regulator - vMax 5.2v vMin shouldn't be less than 5.0v. Make sure these are the voltages at the Pi end of the power lead when the Pi is booting up. Outside of that, use a fresh image on your SD card (I.e. don't put it in a Pi 2 first!) and also check the image checksum matches. Only download the image from the official download page. – Charemer Sep 11 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.