-1

I am trying to install php7.0 on jessie and running into a problem.

$ sudo apt-get install php7.0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package php7.0
E: Couldn't find any package by regex 'php7.0'

I have also tried installing php-fpm with the same result.

My sources.list looks like this

deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi

I can see the package I am after here http://mirrordirector.raspbian.org/raspbian/pool/main/p/

I have tried running sudo apt update and also sudo apt-get upgrade as suggested on other topics but cannot find a solution.

What's odd is I installed the nginx package with sudo apt-get install nginx and this worked without any problem. Is there something I am missing?

  • 1
    If you are happy using an obsolete OS you should be OK with a slightly older php (which is little different from 7.0) – Milliways Sep 12 '19 at 22:38
0

That pool contains packages that are part of all the distro versions that are still actively maintained:

  • v.8, jessie
  • v.8, stretch (aka. "oldstable")
  • v.9, buster (aka. "stable")

And possibly things from v.10, Bullseye aka. testing. If you use the online Debian search tool (Raspbian being a variant of Debian), you can search for things in any of them, which reveals php7.0 is available in oldstable (stretch) only.

You can try and install .debs from other versions directly (download them and use dpkg -i), but no one promises they will work, and chances are you will have to unravel dependencies the same way.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.