2

I've installed Raspian Buster on my RPI 3B. Then installed Eclipse from LXterminal:

sudo apt-get update

sudo apt-get install eclipse

When I run Eclipse (3.8) a startup logo displays and then an error message pops up. A potential fix was to download from eclipse.org and manually install. This gave the same error. Here is the log file content:

!SESSION Thu Sep 12 16:02:26 EDT 2019 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-09-12 16:02:27.158
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
    at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)

This is a commonly reported error but none of the fixes seem to work for me. Anyone got any ideas?

Various forums offer potential solutions to this problem. None have worked for me so far. Maybe Eclipse 3.8 uses a version of java sdk that is different from the one installed in Buster. The eclipse.ini file contains the line:

-Dosgi.requiredJavaVersion=1.8

The default java version in Buster is openjdk 11.0.3 2019-04-16

My attempt to install oracle-java8-jdk from LXTerminal failed as it was "not available" and "package 'oracle-java8-jdk' has no installation candidate"

  • "The default java version in Buster is openjdk 11.0.3 2019-04-16" - are you quite sure? I recently installed a Raspbian Buster image and to my surprise it came with no java whatsoever. – Dmitry Grigoryev Sep 13 at 12:10
  • java -version results in: – user109035 Sep 13 at 13:52
  • java -version shows openjdk 11.0.3 2019-04-16. Did I unwittingly install it? Perhaps. Two tries to install oracle-java8-jdk got the "not available" message from webupd8team. Maybe I can install from a copy. Some background: I made a digital dashboard on my Linux (Ubuntu 18.04 64 bit) laptop with Eclipse Neon & JavaSE-1.8. The runnable jar file failed on my RPI so I wanted to install an eclipse IDE on RPI. If I could open Eclipse I could add the correct JRE but it won't even open. Maybe I could alter eclipse.ini or else attempt to install Eclipse Neon on RPI. – user109035 Sep 13 at 14:29
  • I installed openjdk 8 and verified it was an alternative to openjdk 11. Still got the same exact error. So WTF. Weird that an approved version of Eclipse (3.8) won't open on a fresh copy of Raspian. I don't have these problems on my 10 yr old laptop running Ubuntu 18.04. RPI for my purpose is more trouble than it's worth. I can use a tablet and not have to worry about power supplies, exposed hardware and add-on monitors. Not to mention the hassle of getting the RPI to function as advertised. Good luck to others... – user109035 Sep 13 at 19:18
1

I wanted to install IDE on RPi bc my 64 bit runnable.jar didn't work on Raspian 32 bit OS. Not really sure why not. Gave up on IDE plan and installed Ubuntu Mate 64 bit experimental OS. Converted my project to openjdk/jfx 11 then rebuilt (on laptop computer) and runnable.jar now runs on RPi w/Mate 64 bit. Thanks @Dimitry for help.

  • If the answer from Dmitry Grigoryev does help you, then you should accept it. Tick the tick on the left side of his answer to change its color to green. – Ingo Sep 15 at 10:34
0

I would try to install Oracle JDK. The version you need is "Linux ARM 32 Hard Float ABI" (check dpkg --print-architecture to be sure).

  • Thanks @Dmitry for reply and terminal command. I'm fairly new to Raspian etc. armhf 32 bit is the correct version of JDK and I have a copy. Will try to install. BTW I installed Ubuntu Mate then eclipse (via synaptic package manager) and got the exact same error. – user109035 Sep 13 at 13:17
  • @user109035 AFAIK Ubuntu also comes with OpenJDK. – Dmitry Grigoryev Sep 13 at 13:33
  • *Dmitry You are correct. Ubuntu also comes with OpenJDK. On my laptop with Ubuntu 18.04 and Eclipse Neon I was able to deal with this problem. Eclipse opened and I could load and specify the correct JRE. (Until I did that I got compiler version warnings and runtime errors.) Not so easy to fix on the RPI using Raspian or Ubuntu Mate. – user109035 Sep 13 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.