0

I'm new to Raspberry Pi and I have to make a script based on WiFi connection, but sadly I can't use it.

I have a Raspberry Pi3 Model B+ with the NOOBS sd (the one given with the Premium Kit). I installed Buster version of both Raspbian and Raspbian Full from the recovery mode, but I had the same WiFi issue with Stretch (installed in an old attempt).

Since the installation, I can see every WiFi networks in the nearby, but once I enter the (correct) password of mine, it doesn't connect. I tried to do it with no success either with and without updating the system. I tried to connect to 2 different networks with WPA2 key with the same result, although I can connect to them with no problems from other devices.

I also set the right localisation option into the raspi-config.

I have no problems connecting to Ethernet, but I need to use WiFi. Moreover, every now and then, it connects and works, but after some minutes it disconnects by himself.

Can you please help me? Thank you

  • 1
    And you have restarted the WiFi access point? – MatsK Sep 13 at 10:24
  • @MatsK can you tell me how to do it? – yuki182 Sep 13 at 13:10
1

Please do not touch /etc/network/interfaces if you do not know what you are doing. Please be aware the line in it:

# Please note that this file is written to be used with dhcpcd

To setup WiFi just create a file wpa_supplicant.conf in /boot, something like this, but with your settings:

rpi ~$ cat /boot/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
    ssid="RPiNet"
    psk="verySecretPassword"
    key_mgmt=WPA-PSK
}

And reboot.

Having trouble please follow the official wireless documentation.

To verify your hardware and network environment you can use a fresh flashed Raspbian Buster Lite. Before taking out the SD Card from the Card reader you have flashed it, you must mount the first partition of it. It is the fat formatted partition and will become the /boot directory later on the RasPi. Just create wpa_supplicant.conf as shown above in the mounted directory. Then boot the SD Card in your RasPi. This configuration is known to work. If it is still not working then it is very likely that the problem is not the Raspberry Pi.

  • Right after I changed /etc/network/interfaces before and saw it didn't work, I undid the changes. Anyway I've just tried this, but after the reboot the applet gives "No wireless interfaces found" message – yuki182 Sep 13 at 13:26
  • @yuki182 I have updated the answer with the last paragraph. – Ingo Sep 13 at 15:19
  • can you please tell me how to do it with NOOB sd? I can install Raspbian Lite from there, but then can I create directly that file or will I have to do something else first? – yuki182 Sep 14 at 14:49
  • @yuki182 No, I can't help with NOOB. Most experienced users here do not use NOOB because it is known to make trouble and only waste more than 1GB of SD Card space. To verify your hardware it is really the best to use Buster Lits. If it works then you can try using your own setup, but then you know where you have to look. – Ingo Sep 14 at 15:27
0

As a side note, seeing WiFi networks but being unable to connect is one of the symptoms I've got after switching from Rapsbian Buster repo to regular Debian Buster repo and upgrading. That's obviously not the OP's case, but other people finding this question might find it useful.

Note that there's no easy way to undo an arbitrary upgrade involving many packages, so the solution in this case is to reinstall Raspbian from scratch.

  • Possibly firmware; what kernel was Debian running? – goldilocks Sep 13 at 15:40
  • @goldilocks I didn't really investigate, I just rolled back the Raspbian image and took a mental note not to upgrade the system if I ever need to install something from the Debian repo. – Dmitry Grigoryev Sep 13 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.