Hi i tried extracting a multi part rar files using unrar-free but it does not work and i get an error saying "failed"

I followed this guide below :

Uninstall unrar-free.

$ sudo apt-get remove unrar-free

Make sure you have a source repository by editing /etc/apt/sources.list.

$ cat /etc/apt/sources.list
# Default repository
deb http://archive.raspbian.org/raspbian wheezy main contrib non-free rpi
# Source repository to add
deb-src http://archive.raspbian.org/raspbian wheezy main contrib non-free rpi

Sync the apt database.

$ sudo apt-get update

Create a working directory and move into it. The unrar-nonfree command will be built in this directory.

$ cd $(mktemp -d)

Install the dependencies required by unrar-nonfree.

$ sudo apt-get build-dep unrar-nonfree

Download the unrar-nonfree sources and build the .deb package.

$ sudo apt-get source -b unrar-nonfree

Install the generated .deb package. Its name varies depending on the version of unrar-nonfree.

$ sudo dpkg -i unrar*.deb

The working directory you have created in step 4 will be removed at next boot; there is no use to delete it.

When i edited my source.list and then do a sudo apt-get update i get this error below:

Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Ign:3 http://archive.raspbian.org/raspbian wheezy InRelease
Err:4 http://archive.raspbian.org/raspbian wheezy Release
  404  Not Found [IP: 80]
Reading package lists... Done
E: The repository 'http://archive.raspbian.org/raspbian wheezy Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Is there another tool i can use instead of this or can anybody help me fix this error?


2 Answers 2


The information is obviously some years old; wheezy and buster are distro versions, the former being no longer supported. Your source.list should instead read:

deb http://archive.raspbian.org/raspbian buster main contrib non-free rpi
deb-src http://archive.raspbian.org/raspbian buster main contrib non-free rpi

Ie., adding the deb-src and non-free stuff to buster, not wheezy.


I fixed it by adding Jessie instead of weazy in the source set

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.