0

Can anyone tell me why rtl8188eu is not "just working" in vanilla Raspbian Buster?

I was using Raspbian Stretch until now, and all I had to do to configure wifi with my network card after flashing image to RPi Compute Module 3 was this:

# wpa_passphrase MySSID MyPass >> /etc/wpa_supplicant/wpa_supplicant.conf
# reboot

# ping google.com
# voila - everything works!

Now I decided to use Buster. My device is properly detected (I see Realtek 8188 it when I run lsusb or lsmod), but after adding my WiFi configuration to wpa_supplicant.conf - it doesn't work.

What is going on?

  • 1
    can you show the full content of /etc/wpa_supplicant/wpa_supplicant.conf (hide the SSID and PSK of course – Jaromanda X Sep 15 at 10:53
  • Try using Mr Engmans' script to get a working driver for your 8188eu. downloads.fars-robotics.net/wifi-drivers/install-wifi – Dougie Sep 15 at 14:20
  • "I see it when I run lsusb" -> That will happen no matter what, since it is just information provided by the device using the base USB protocol which will happen with any and all USB devices whether or not a driver exists for them (it is this information that is used to select a driver, if one is available). – goldilocks Sep 15 at 15:09
  • What would confirm whether or not the driver is working or not on some level would be the output from ip link. – goldilocks Sep 15 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.