0

I'm guessing that the lxpanel applet called Wired & Wireless Networking is just a front-end for this executable. But what is the executable?

Why I want to know: because this executable keeps giving eth0 a link-local address and that's messing with how I need to handle the network. This mystery executable and its panel applet couldn't do VPNs or PPPOE, and the traditional linux network-manager system was having trouble with PPPOE on the built in ethernet socket of my Pi 2b.

So I did my own thing and wrote a set of bash functions, using the ip, pon and openvpn commands that do everything I want (including VPNs and PPPOE) and I'm happy with how it turned out, but this mystery Raspbian networking executable keeps stepping in and giving eth0 a link-local address!

Problem: This stops my PPPOE working, so my bash functions counter it by using ip to flush the addresses of eth0. This works, but I'd really like the mystery Raspbian networking executable uninstalled or at least not running.

(Extra detail: I think I can see why the link-local address is being chosen by this executable: right clicking on its lxpanel applet then chosing the top menu item and then "interface" and "eth0" in the drop downs allows manipulation of a check box saying "Automatically configure empty options". I guess this sets the networking executable to try DHCP for a while then gives up and assigns a link local address. If you uncheck the box it just checks itself again when you click apply, and I tried unchecking it and just giving 0.0.0.0 for eth0's ipv4 but that caused the panel applet to oscillate quickly between two different icons forever, and goodness knows what trouble that might cause behind the scenes).

What I've tried: All I can find on Google is how to install network-manager, and like I said, that's not the answer for my project on the 2b so I'm a bit lost.

That's all the whys and all the facts I know; thanks for reading this complicated question. Can anyone figure out what this mystery executable is that handles network connections by default in Raspbian?

SOLVED BY USER GOLDILOCKS IN ANSWER BELOW: To expand on that answer with some code, the mystery executable is dhcpcd and Raspbian runs it as a systemd service. So I'm getting very good results after using:

sudo systemctl disable dhcpcd

That should prevent dhcpcd starting on boot, though it will still be running in the current boot, so

sudo systemctl stop dhcpcd

will stop it now if you want it out of the way immediately. If you're doing that you might also want to remove any link-local ip addresses it gave to eth0

sudo ip addr flush eth0

Encouragingly, with dhcpcd not running the Wireless and Wired Network Settings lxpanel applet is now non-functional. The above has fixed my pppoe problem. I know nothing about systemd though, so please post advice and criticisms if I've missed things.

  • Excellent. I'm now geting good results asfter using with "sudo systemctl disable dhcpd" which prevents the service from starting on boot – user224016 Sep 15 at 14:44
  • I'll post that as an actual answer then so you can tick the big checkmark next to it indicating the question is satisfactorily answered, please and thank you. – goldilocks Sep 15 at 15:04
0

It is dhcpcd now by default; check with systemdctl status dhcpcd, so you could experiment with how using the widget (I never have) affects dhcpcd.conf, and the stuff in /etc/networking and possibly the hooks (active ones are in /etc/dhcpcd and /lib/dhcpcd).

I would guess it is the widget misbehaving as the people responsible for that != the people responsible for dhcpcd. BTW, if you are handy with shell scripting writing your own hooks may streamline what you've already done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.