3

I need to install Rasbian Stretch on Pi 4.

  • 3
    Why do you need Stretch? – CoderMike Sep 15 at 21:05
  • @CoderMike Using a piece of hardware with old drivers could be one reason. For instance, I bet many of el-cheapo SPI display modules will never receive a Buster update. Though I agree that the OP should explain their reasons, because a workaround may exist which doesn't involve installing Stretch. – Dmitry Grigoryev Sep 16 at 6:57
8

You cannot install Raspbian Stretch on a Raspberry Pi 4B. The RPi 4B does not support it as you can read in the release notes in section from 2019-06-20. A RPi 4B is only supported by Raspbian Buster.

2

All you have to do is compile (and debug) all the Stretch code with the new firmware needed by the Pi4. The Foundation decided it was not worth the effort.

1

I have just released a script that will run a Raspbian Stretch virtual machine, inside the Raspbian Buster operating system. Not sure if it will work in your case, but it is definitely something to try before attempting to compile Stretch! vdesktop script

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.