0

When I plug a USB keyboard into my Raspbian (buster) pi 3B+, and I try to use the pipe key | I get a tilda ~ instead. This is consistent across a bunch of keyboards that work well in other computers.

I see in raspi-config under "Localisation Options" I can "Change Keyboard Layout". There's a long list, so I pick something generic like "Logitech" and then it asks me to configure the "Keyboard layout". Here it presents a long list of options in Cyrillic and Greek and non-English languages but nothing that looks appropriate for USA/English, or even anything that looks Western-European. Even under something plausibly simple like "Frans" I see a huge list of choices, again with lots of Cyrillic and Greek that all look wrong, and make me worried my keyboard will become completely useless if I select one.

To be as clear as I can about version I'm running:

$ uname -a
Linux leopi6 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux

$ cat /etc/os-release 
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
  • No "English (US)" option after you pick the keyboard? (Sorry, edited) – abolotnov Sep 18 at 18:12
  • Nope. No English (US) option in sight. I've got Albanies or Yslandies or испанска — латиноамериканска or черногорска or lots in between. – Leopd Sep 18 at 18:17
  • Wow, what are you running? If you picked Generic-101 key there will be no Eglish layouts to pick from when you scroll? – abolotnov Sep 18 at 18:25
  • Raspbian buster - details in main question. Also, FWIW there's no "Generic-101" in the keyboard list. There's "Generies 101-sleutel PC" which google tells me is Afrikaans for "Generic 101 key PC". – Leopd Sep 18 at 18:34
  • 1
    I've seen that raspi-config mess (to be fair, I don't think it is raspi-config that created it) using a fresh Raspbian lite buster install. It's totally broken, but you can do it manually. Gimme a minute to see if I can remember how. – goldilocks Sep 18 at 19:17
2

Here it presents a long list of options in Cyrillic and Greek and non-English languages but nothing that looks appropriate for USA/English, or even anything that looks Western-European. Even under something plausibly simple like "Frans" I see a huge list of choices, again with lots of Cyrillic and Greek that all look wrong

I have seen this screen and it is clearly not working properly.

Edit /etc/default/keyboard and set:

XKBMODEL="pc101"
XKBLAYOUT="us"

The second one is what's most important; it was probably (gb). Then reboot. This should be permanent and affect both console and GUI mode.

See also man 5 keyboard for an explanation of where to find available options, etc.

  • Thank you so much!! raspi-config is great when it works, but... – Leopd Sep 18 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.