1

I am trying to get a SIM7600E-H-4G-HAT running on my Raspberry Pi 3B+, but it is not working. Here is what I've done so far:

  1. Inserted my SIM-Card, connected the antenna to Main, connected the entire hat via GPIO pins to my Pi without any USB cable connected to that hat. I left the two yellow jumpers factory-default like, centered just as pictured in the manual.

  2. I booted the raspberry, set via raspi-config the serial options as described in the manual (no, then yes).

  3. chmod 777 for sim7600_4G_hat_init and added sh /home/.../sim7600_4G_hat_init to rc.local

  4. Rebooted, installed minicom, started sudo minicom -D /dev/ttyS0 and nothing happens and it does not even react on any keystroke. I even compiled the bcm2835 directory and the phoncecall-demo. When I try to sudo ./Phonecall it says

Failed to get byte count on serial.

Both LEDs shine red permanently. What am I doing wrong?

  • 1
    You are doing wrong to use rc.local if using an operating system with systemd like Raspbian or Ubuntu or arch. Please take note that using /etc/rc.local has limitations due to Compatibility with SysV. We have seen many problems here on this site using it. Following the recommendation of the developers from systemd you should avoid using it. – Ingo Sep 20 '19 at 22:28
  • Ah let me see. I skimmed your user manual: "SIM7600E-H 4G HAT User Manual, Rev 1.0 - WaveShare 2018jun08": waveshare.com/w/upload/6/6d/SIM7600E-H-4G-HAT-Manual-EN.pdf and read Section3 "Using with Rpi" specifying the following Rpi to SIM7600 interface: (1) Pin 22 (BCM P6), Power up the module, (2) Pin 07 (BCM P4), Pull high enable flight mode. So I guess the sim7600_4G_hat_init should unitialize pins BCM P6 and BCM P4, among other things. Now what you did the following might have a problem: (3) chmod 777 sim7600_4G_hat_init, / to continue, ... – tlfong01 Mar 17 at 6:44
  • (4) add to file: "/etc/rc.local filesh" the following bash command: "/home/pi/SIM7600X/sim7600_4G_hat_init", because (5) as @ingo says /etc/rc/local might not be compatible to your raspbian stretch or buster, (6) Your init program might be out of date and not compatible to your raspbian, (6) Furthermore, your following setup looks OK: (c) sudo apt-get install minicom, (d) minicom -D /dev/ttyS0. But I have two troubleshooting suggestions: / to continue, ... – tlfong01 Mar 17 at 6:45
  • SUGGESTION ONE:(7) You might like to do the following loopback test: "BEFORE INSERTING SIM7600, short RxD to TxD and make sure minicom can loopback". SUGGESTION TWO: Do not test SIM7600 in HAT mode but test first in standalone UART serial AT command control SIM7600 mode: (e) set jumeper to "C", use Win10 terminal emulation program puTTY, me prefer RealTerm, or Rpi terminal emulation program miniCom, me prefer CuteCom to test AT commands. I use RealTerm to send "AT" and recvived "OK" before the real tests. :) / to continue, ... – tlfong01 Mar 17 at 6:45
  • If both of my suggestions OK, then you go back to try the Rpi HAT mode, which is a bit complicated (with three USB ports for AT mode, GPRS mode, and Debug mode. Cheers. – tlfong01 Mar 17 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.