0

I can't seem to install the latest version of mongoDB on Raspberry pi 4. I have tried doing

sudo apt-get install mongodb 

This installs mongoDB 2.4.

  • 1
    I thought MongoDB needed a 64-bit OS. The current Raspbian version is 32-bit. So you either need to try with the Gentoo64 OS, try with the experimental Raspbian 64 kernel or try installing an old 32-bit version of Mongo. – Dougie Sep 20 '19 at 22:10
  • 1
    You have already installed MongoDB raspberrypi.stackexchange.com/q/103781/79866 and you wrote here again "This installs mongoDB 2.4". So what's the question? Do you want another version? – Ingo Sep 20 '19 at 22:19
  • Just now I tried your command to install mongodb. A couple of minutes later, I got the message "Processing triggers for systemd (241 ...), then *** Error: Timeout was reached ***. Are you asking how to solve the timeout problem? – tlfong01 Sep 21 '19 at 4:14
  • no, it installs fine however when I go to run my node.js app it then creates an error which says that the version of mongodb installed is not up to date and doesn't work with the node mongo drivers – mbh16 Sep 21 '19 at 13:33
  • I have tried the Raspian Buster 64 Kernel and the same has happened. – mbh16 Sep 21 '19 at 19:59
-2

Maybe try

sudo apt-get install -y mongodb-server
  • 2
    Please explain why do you believe that this will install the latest version of MongoDB and not version 2.4.14 as given in the default Raspbian repository. – Ingo Nov 22 '19 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.