0

I need help, can anyone solve this problem? My Raspberry Pi can't update and is showing this when I run sudo apt update:

sudo apt update output with some signing errors

How can I fix this?

  • Try using wget or a something (even a web browser) after this happens with each of those hosts (eg., just wget https://repo.mosquito.com) and edit in the output from that. Are you using a proxy server or behind an institutional firewall? – goldilocks Sep 23 at 14:00
  • 1
    Please don't use pictures of text. Instead paste the text output direct into the question. – Ingo Sep 23 at 18:17
0

Maybe it is a problem with your mirror. Even my closest mirror right now is down (ireland). Maybe this issue could be fixed by changing mirror.

You can change the apt source/ repo by and fix this issue by:

$ sudo nano /etc/apt/sources.list

Then you edit the first line by adding a # at the beginning. Add the the end of the line:

deb http://mirror.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian buster main contrib non-free rpi

Your file should look like this:

   #deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-$
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
 #deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib $
    deb http://mirror.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian buster main contrib non-free rpi

Then Ctrl-x to save + Y Then :

 $ sudo apt-get update

The issue could now be fixed

-1


See apt-secure for details. I would check that out.

Update system's package list
sudo apt-get update
Then upgrade all installed packages to latest version
sudo apt-get dist-upgrade

For more info check out the website. (https://manpages.debian.org/jessie/apt/apt-secure.8.en.html)

  • With executing apt-secure I get -bash: apt-secure: command not found. – Ingo Sep 23 at 18:19
  • There are other people having similar problems with this. Looks like how they solved it was to flash a new image.(raspberrypi.stackexchange.com/questions/93243/…) – Daniel Sep 24 at 1:41
  • I have executed the command on a fresh flashed Raspbian Buster Lite. Your answer is wrong. – Ingo Sep 24 at 8:48
  • Did you try sudo apt-get clean – Daniel Sep 24 at 18:01
  • Trying that command doesn't correct your answer. You should edit and correct the answer. – Ingo Sep 24 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.