1

Im trying to install ROS Kinetic on my Raspberry Pi which is running Raspbian stretch.

When i enter

sudo apt-get install ros-kinetic-desktop-full

it returns

E: Unable to locate package ros-kinetic-desktop-full

I also tried to install ROS without apt-get but then i need to install all packages like rviz en rqt myself by cloning them from git, and i want to do that with apt-get

1

Have you followed the installation manual (http://wiki.ros.org/kinetic/Installation/Debian). For me it looks like you either never updated your sources list or you did it but never updated your package index.

You have to:

  1. Setup your sources.list (sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list')
  2. Set up your keys (sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654)
  3. Update your package index (sudo apt-get update)

before you can start installing the package.

EDIT: ROS Kinetic only supports jessie. You can try if sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu jessie main" > /etc/apt/sources.list.d/ros-latest.list' works but there is absolutely no guarantee for it. You better should build ROS from source (http://wiki.ros.org/kinetic/Installation/Source)

  • after i did this the error is still the same – KnakworstKoning Sep 24 '19 at 9:38
  • I also installed dirmngr – KnakworstKoning Sep 24 '19 at 9:39
  • After looking carefully at the installation page I saw the following: "ROS Kinetic ONLY supports Jessie (Debian 8) for debian packages" – Stefan Wegener Sep 24 '19 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.