1

New to the Raspberry Pi game. I recently received a RPi4b 4Gb for my birthday, I want to use Raspbian Lite. After writing to a 32Gb micro SD card with 'balenaEtcher', sorting out the mess of wires and powering up I see the rainbow square flash, the boot information with all the green [Ok] s scrolling by, roughly two seconds of the boost info scrolling by - the number was at 1.x is all OK, 2.x is all ok, it mentions something about 'starting x' - the (TV) screen turns black, flashes black, and then turns to solid black. Im not sure if its receiving no input however when I unplug the HDMI cable I can see my TV screen 'updating' or 'adjusting'. Regular Raspbian works fine, Im loaded in without any problems, I've tried Raspbian Lite "2019-07-10-raspbian-buster-lite" and "2019-06-20-raspbian-buster-lite". Any help would be much appreciated, I've tried to include as much information about my issue as possible, if I need to add anything else please tell me.

3
  • Not sure what your Raspbian Lite issue is but you could just set Raspbian with Desktop to boot to CLI using Raspberry Pi Configuration.
    – CoderMike
    Sep 25 '19 at 17:20
  • You should enable ssh so you can ssh into the RasPi for troubleshooting and looking at the log files if the TV screen fails.
    – Ingo
    Sep 27 '19 at 8:31
  • We do not mark questions as [Solved]. The right way to do it here is to create an answer with the solution. Then you can also remove your UPDATE:. Please do it.
    – Ingo
    Sep 27 '19 at 17:49
2

Commenting out the FKMS line in the config.txt file has fixed my issue, see https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=252712&p=1542121#p1542121 for full

1

It might have to do with the TV screen resolution. Is there a resolution setting on the TV screen you can change/adjust, possibly to some common "standard" resolution (i.e. not anything too exotic)?

If the screen resolution really is the culprit here and if you are able to find a resolution setting that works, you can use that resolution temporarily to boot up your pi and change the display configuration settings of your pi to the resolution that matches the TV screen resolution you really want (if the pi supports it). I do not have a RPi4B and do not know the exact details, but here is a link which explains how to change the display settings of the pi (scroll down to hdmi_group and hdmi_mode)

More info specific to Buster:

A few features of the old non-OpenGL video driver (such as pixel doubling and underscan) are not currently supported by the new OpenGL driver, so the settings for these are hidden in Raspberry Pi Configuration if the GL driver is in use. (The GL driver is the default on Raspberry Pi 4 – older Pis will still use the non-GL driver by default. Also, if using a Raspberry Pi 4 headless, we recommend switching back to the non-GL driver – choose ‘Legacy’ under the ‘GL Driver’ setting in ‘Advanced Options’ in raspi-config.)

Finally, there are a couple of new buttons in ‘Raspberry Pi Configuration’ which control video output options for Raspberry Pi 4. (These are not shown when running on earlier models of Raspberry Pi.) It is not possible on the Raspberry Pi 4 to have both analogue composite video (over the 3.5mm jack) and HDMI output simultaneously, so the analogue video output is disabled by default. 4Kp60 resolution over HDMI is also disabled by default, as this requires faster clock speeds resulting in a higher operating temperature and greater power consumption. The new buttons enable either of these options to be enabled as desired.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.