0

I have an issue with Rasbian lite.

I downloaded the OS and installed it in a Raspberry PI Model 3B. logged in and typed the following:

  • sudo raspi-config
  • added wifi access point name and password
  • saved and finished

this closed the raspi-config tool

I then typed ifconfig

ifconfig shows the Wlan0 without an IP address

wlan0 : flags=4099,UP,BROADCAST,MULTICAST>.   mtu 1500
      ether xx:xx:xx:xx:xx. txqueuelen 1000 (Ethernet)
      RX packets 0.  bytes. 0. (0.0B)
      RX errors 0 dropped 0 overruns 0 fram 0
      TX packets 0. bytes 0. (0.0B)
      TX errors 0 dropped 0 overrun 0 carrier 0 collisions 0

There is suppose to be a line that read :

inet 169.123.1.netmask 255.255.255.0

This is not in the ifconfig.

I cannot ping a local or internet IP address I do not have access to the internet.

I tested the hardware and the network credentials using the rasbian OS with Desktop. That worked.

  • The hardware works
  • The WIFI credentials work
  • The full version of Rasbian works...Not the Lite version.

Why is this error happening when I attempt to use Rasbian lite (Stretch and buster)?

  • 2
    You must have done something wrong, but The WIFI credentials work is meaningless; you need to list the contents of /etc/wpa_supplicant/wpa_supplicant.conf (you can obfuscate your password). PS do not use ifconfig use ip a – Milliways Sep 26 at 22:09
  • I always use "$ hostname -I" to get the ip addresses. My head is too small to remember other methods, like looking into /etc/..., /boot... or other "$ abc" commands which work for raspbian wheezy but no longer jessie, or jessie ok but no longer stretch, and of course stretch Ok but sorry, not for buster. And also full version ok but not lite, and lite ok but not full version, or full version ok but no full version with recommended software. I started to keep a record of setup/init/config notes each os version, but I found the notes I wrote earlier no longer useful, some became plain wrong. – tlfong01 Sep 27 at 0:55
  • I need help with the intent of the question. Sorry, these comments do not offer me any I can try. – Spineless Sep 27 at 1:15
  • as first comment says ... show the contents of /etc/wpa_supplicant/wpa_supplicant.conf (hide your ssid/password if you want) – Jaromanda X Sep 27 at 3:01
  • To elaborate it a bit more: please open a linux terminal so you can execute commands on the command line. Then execute this command: sudo cat /etc/wpa_supplicant/wpa_supplicant.conf. This should output the contents of that file. You can select this text output with your mouse and copy and paste it into your question that you have opened for editing (there's a link under it) in your browser. – Ingo Sep 27 at 9:20
1

As has been mentioned in the comments, you should use ip addr instead of ifconfig.

Your ifconfig output doesn't show the RUNNING flag. The output of ip addr (or ip link) would probably not include the LOWER_UP flag. That means that contrary to your claims the WLAN is not connected, therefor it can't obtain an IP address.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.