1

I recently bought a new raspberry pi model B with 4GB rams and I copy & paste Noobs in the micro SD card from macbook.

I plugged my HDMI cable from my raspberry pi to samsung TV but it always shows "No Signal". The HDMI works for sure (I use it for my switch), I also tested my raspberry in the office with a monitor and I can see the output.

I did a lot of search on internet, the most common suggest is to modify the "config.txt" file with hdmi_force_hotplug=1, config_hdmi_boost=4, ect, but there is no such file in the Noobs. Then I've tried to install the Raspbian and modified the file with the parameters above but nothing works.

I'm new on raspberry bi and I don't know which part I did wrong, could be the problem of TV or some signal settings? Does anyone have any solution for it? Thanks!

  • 1
    The "config.txt" is /boot/config.txt on the pi. To edit use "sudo nano /boot/config.txt", and you will have to reboot after changing. Try removing the # from the config,txt line for "#hdmi_safe=1" then reboot while plugged into your TV. – Don Sep 29 at 16:35
  • 1
    Try swapping the HDMI from HDMI1 to HDMI0 (nearest the USB-C power connector). Try running sudo apt update; sudo dist-upgrade -y; sudo reboot to get the latest Raspbian fixes. – Dougie Sep 29 at 17:11
  • @Don Thanks for the reply, I've tried to remove the comment # but it don't work, and I don't have any monitor but only TV to access to my pi :/ – Terry Sep 29 at 18:06
  • @Dougie Thank you but I've tried both HDMI ports and none of them works. I can't run these commands because I don't have other monitor to access to my pi... – Terry Sep 29 at 18:07
  • Get a new SDCard, get Raspbian on it. Put your wpa_supplicant.conf and a blank ssh.txt in the /boot folder (you can do that on windows - as long as you ignore any prompts that encourage you to reformat the filesystem). Boot that and you can ssh in to your RPi (you may need to scan your network or look at your router's config pages to find the IP address). Then you can run those commands to see what's going wrong. – Dougie Sep 29 at 18:56
1

Try adding this to /boot/config.txt; I had a lot of trouble with a Hannspree HT161 that has a resolution of 1366x768 - this sets to closest HDMI res of 1360 x 768

hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=87
hdmi_cvt=1360 768 60 3
  • Thanks for the reply @Don, I've tried your settings but it still doesn't work :( My TV is Samsung bought in France (samsung.com/fr/support/model/UE32J4100AWXZF) I don't know if there is something like frequency that pi won't support or needed to add some additional settings... – Terry Oct 15 at 19:36
  • @Terry I've looked up the specs for that TV and would expect it to work. Back to basics: try the other HDMI port on the TV (not the one used for Switch). – Don Oct 16 at 9:20
  • I've already tried other HDMI port... and the HDMI cable and the adapter work fine on other devices... – Terry Oct 16 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.