0

I haven't used my zero in about a year and I am trying to connect it to my new WiFi with no real success.
I tried:

-Editing the wpa_supplicant.config file and adding a shh file but when I check the network I show no new devices connected

-Reinstalling Raspbian Buster Lite

-Connecting the pi to a TTL Serial Cable but no devices show up when I run ls /dev/cu.* I added enable_uart=1 at the end of the config file and installed two drivers for console output on Macs to no avail

I am trying all this on a mac and am using a Raspberry Pi Zero W v1.1. Does anyone know why I wouldn't be able to connect to WiFi or even serial log to my Mac?

Thanks!

Update: Here is the code to my wpa_supplicant.conf file

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="user"
    psk="pass"
}
4
  • 1
    wpa_supplicant.config it should be called wpa_supplicant.conf ... adding a shh file - that should be called ssh - and both of these files should be put in the boot partition (the first partition) ... ssh just an empty file, and the wpa_supplicant.conf needs to be correct - show what you've put in that file – Jaromanda X Oct 1 '19 at 1:21
  • @JaromandaX I updated the original post – Aaron Rotem Oct 1 '19 at 1:42
  • You missed using key_mgmt=WPA-PSK on your wpa_supplicant.conf. I followed this guide when setting up my Pi styxit.com/2017/03/14/headless-raspberry-setup.html. – admin Oct 1 '19 at 7:54
  • By 'serial log' do you mean log in via a USB->Serial adapter? How are you trying to do this? Does logging in with a keyboard and a monitor connected to the HDMI port work? – Fred Oct 4 '19 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.