Have an owncloud on a raspberry, available from public network e.g. from the IP of my router rather than from the IP of my Raspberry.

Background info

root@DietPi:~# uname -a
Linux DietPi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux
root@DietPi:~# cat /etc/issue.net
Raspbian GNU/Linux 9
root@DietPi:~# cat /proc/version
Linux version 4.19.66-v7+ (dom@buildbot) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611)) #1253 SMP Thu Aug 15 11:49:46 BST 2019


I am following mainly this guide here: https://www.avoiderrors.com/set-up-raspberry-pi-owncloud-server/

Currently Everything is working fine with local settings, ( e.g. on ).

On my router(tp-link) I have set the following virtual server:

Service Port - 80
Internal Port - 80
IP Address -    192.168.0.xxx
Protocol - TCP

Final change

as said in the guide, I have edited the config.php file like so:

  'trusted_domains' => 
  array (
    0 => 
    1 => '<real ip>',
  'overwrite.cli.url' => 'http://<real ip>/owncloud',

After this change

http:///owncloud is not working from a computer being hooked to the same router.



  1. Tried restarting PI
  2. Tried restarting router, editing config.php again
  3. Tried connecting from a different source
  4. Tried playing with config.php

Meanwhile, the local owncloud was still working perfectly.

Found something interesting in the tp-link admin page (, the ISP had set an option in Network->WAN->WAN Connection Type: -> PPPoE/Russia PPPoE with user and password

I haven't tried other routers on other ISPs.


Can you advise how should I troubleshoot this issue?

  • You have tagged your question Raspbian but appear to be using something else. – Milliways Oct 2 '19 at 23:15
  • The local owncloud was still working perfectly. Do you ask how to troubleshoot your router? Isn't DietPi a distribution like Raspbian? Are you using DietPi or Raspbian? – Ingo Oct 3 '19 at 9:55
  • @Ingo DietPi is the proper Distro, which is based on Raspbian – Harton Oct 7 '19 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.