-2

What I need to do is PXE boot:
https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/net.md


however I did not get 17:3020000a,

If found another link : https://blockdev.io/network-booting-a-raspberry-pi-3/
it mention to Update the Pi (firmware)
sudo BRANCH=next rpi-update

Raspberry Pi 4

curl: (7) Failed to connect to raw.githubusercontent.com port 443: 
Connection timed out
 !!! Failed to download update for rpi-update!
 !!! Make sure you have ca-certificates installed and that the time is set correctly

1) I installed CA Certificates : sudo apt-get install ca-certificates
2) I checked the time it is correct to my location.
Do I need to set my time to another location? I am on PDT, Do I need to set it to UTC!
3) I tried to sync time: sudo ntpdate -u ntp.ubuntu.com.No server suitable for synchronization found!!

Any suggestion?

  • Operating system? – Ingo Oct 3 at 10:35
3

There's a very valid reason why rpi-update tells you that it's experimental code and may leave your RPi unbootable.

There is no valid reason why anyone should run rpi-update unless advised to do so by an expert from the Raspberry Pi Foundation or Raspberry Pi (Trading) Ltd.

Running rpi-update with BRANCH=next will back-level your firmware and kernel by EIGHT months (before the RPi4 was launched) and WILL leave your RPi unbootable.

  • Thanks, what I need to do is PXE boot: raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/… , however I did not get 17:3020000a, If ocund another link : blockdev.io/network-booting-a-raspberry-pi-3 it mention to Update the Pi (firmware) – Rastin Oct 3 at 18:30
  • That doesn't need rpi-update all the PXE support for RPi3B/3B+/3A+ is in plain Raspbian 2019-09-26. With a 3B you'd need echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt. That isn't needed on 3B+ or 3A+. BTW, that support is NOT YET AVAILABLE on any RPi4B models. – Dougie Oct 3 at 21:58
  • Dougie, Thanks, when it would be available on RPi4? where should look for? – Rastin Oct 7 at 18:50
  • The Raspberry Pi Foundation and Raspberry Pi Trading Ltd. have not announced any date when PXE will be available on an RPi4B. You'll have to sit patiently and wait for that support to be ready (it could be six months away). – Dougie Oct 7 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.