0

As said in the title mysql_secure_installation gives this error,I've tried finding a sock file anywhere associated with mysql,no trace,my.cnf has no path written for the sock,neither mysql nor mariadb services can be started,I've been looking for more than an hour at the internet for a solution,nobody asked the same thing,I can't seem to find any answers for my problem.(It worked once but I had to format the card and reinstall raspian,I did everything the same way,but it just won't work)(I'm trying to set up a web server for a project website)

  • This question seems to have little to do with Raspberry Pi Desktop - a operating system for PC and Mac. We don't know what you are using or what you have actually done. – Milliways Oct 4 at 6:55
  • Is MySQL (or, more likely, MariaDB) running? The default configuration has a socket = /var/run/mysqld/mysqld.sock defined in it. – Dougie Oct 4 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.