1

I've been going over so many web pages trying out numerous things for the past 6 hours to just get internet on my rpi to no avail hence I have come here to hopefully find a solution. Below are the list of things I have done.

I am using an rpi zero (without inbuilt wifi) and a windows 10 laptop and have Bonjour installed

  1. I cleaned my SD card and etched Raspbian Buster Desktop using Etcher
  2. Added an empty file named "ssh"
  3. Added dtoverlay=dwc2 to config.txt
  4. Added modules-load=dwc2,g_ether to cmdline.txt ;after rootwait
  5. I am able to ssh into pi using putty with no issues
  6. I can see the RNIDS gadget in device manager and the
  7. I went to network and sharing in control panel then went to sharing tab of my main wifi, then checked the box for sharing the network and selected "ethernet 3"(rpi zero) from the drop down.

I have tried apt-get update, different installs and rpi-update but none of them work as I assume that I can't access the internet. An exmaple of one such error is as follows:

 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:09 --:--:--     
 0curl: (6) Could not resolve host: raw.githubusercontent.com
 !!! Failed to download update for rpi-update!
 !!! Make sure you have ca-certificates installed and that the time is set 
 correctly

Another sort of error I get when i try to update anything is:

Err:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Temporary failure resolving 'raspbian.raspberrypi.org'

ifconfig is as follows:

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    inet 127.0.0.1  netmask 255.0.0.0
    inet6 ::1  prefixlen 128  scopeid 0x10<host>
    loop  txqueuelen 1000  (Local Loopback)
    RX packets 710  bytes 67146 (65.5 KiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 710  bytes 67146 (65.5 KiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
      inet 169.254.19.18  netmask 255.255.0.0  broadcast 169.254.255.255
      inet6 fe80::3af9:58d:482c:9910  prefixlen 64  scopeid 0x20<link>
      ether a2:a6:f5:42:ee:0e  txqueuelen 1000  (Ethernet)
      RX packets 1402  bytes 167050 (163.1 KiB)
      RX errors 0  dropped 0  overruns 0  frame 0
      TX packets 1996  bytes 293158 (286.2 KiB)
      TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

ping -c3 8.8.8.8 as follows:

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 169.254.19.18 icmp_seq=1 Destination Host Unreachable
From 169.254.19.18 icmp_seq=2 Destination Host Unreachable
From 169.254.19.18 icmp_seq=3 Destination Host Unreachable

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 46ms
pipe 3

ping -c www.google.com as follows:

ping: www.google.com: Temporary failure in name resolution

Would appreciate any help to solve this long standing issue of mine.

Please let me know if there is anymore info that i can give to help me solve this issue.

  • The fact the ´usb0´ get ´169.254.19.18´ indicate that you have missed some steps in the configuration. Please follow the instruction to the letter at circuitbasics.com/raspberry-pi-zero-ethernet-gadget and then let us know where it fails. – MatsK Oct 6 at 8:51
  • 1
    It looks like the Ethernet gadget half of everything is working just fine, which leaves the Internet Connection Sharing side of things as not working. How have you configured that? Theses posts might be helpful to look at: raspberrypi.stackexchange.com/questions/13941/… raspberrypi.stackexchange.com/questions/63153/… – Fred Oct 6 at 8:53
  • @MatsK I have done all the steps in the tutorial namely, update the driver, expand the file system, then tried sudo ping www.google.com but got "ping: www.google.com: Temporary failure in name resolution" error. I then shared the main internet to ethernet 3 (rpi zero) and tried the ping again but got the same error. – Roshan Oct 6 at 9:23
  • As I wrote in the beginning: If you get 169.254.19.18 that is a clear indicator that something is WRONG. APIPA (webopedia.com/TERM/A/APIPA.html) is a IP adr that the machine assigns to it self when it cant get a adr from a DHCP server. Have a look here packetlife.net/blog/2008/sep/24/169-254-0-0-addresses-explained – MatsK Oct 6 at 11:00
  • You appear to be trying to use your laptop to provide internet access - this is OK (but configuring it is a Windows problem) BUT you will need a keyboard and screen on the Pi. You can only have Internet Connection Sharing OR sshaccess NOT BOTH. The only way of achieving this is to connect the Pi to your router (or add another interface). – Milliways Oct 6 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.