1

I have a B+ running rasp stretch and I am attempting to follow this tutorial to upgrade to 3.7 but I have an issue at the this step:

./configure –prefix=/usr/local/opt/python-3.7.0
make -j 4

Any ideas to get around this?

pi@raspberrypi:~ $ tar xf Python-3.7.0.tar.xz
pi@raspberrypi:~ $ cd Python-3.7.0
pi@raspberrypi:~/Python-3.7.0 $ ./configure –prefix=/usr/local/opt/python-3.7.0
configure: error: invalid variable name: `–prefix'
pi@raspberrypi:~/Python-3.7.0 $ make -j 4
make: *** No targets specified and no makefile found.  Stop.
  • 2
    Why not just flash Raspbian Buster - it comes with Python 3.7 – CoderMike Oct 7 '19 at 13:56
  • ah Ok, can you post an answer for how to upgrade to buster? – HenryHub Oct 7 '19 at 14:03
  • You can't upgrade - you have to re-flash – CoderMike Oct 7 '19 at 14:21
  • @CoderMike that's not strictly true. You can upgrade from Stretch to Buster but it may not work for everyone and Buster may not include all of the packages in Stretch. It's not recommended but it is possible. You may miss new packages, you may break things (like the Google AIY stuff). – Dougie Oct 7 '19 at 15:20
  • I ended up following this post to upgrade to buster – HenryHub Oct 9 '19 at 19:24
1

it's --prefix not -prefix (if you copy-pasted, just remove the - and manually type -- (who hyphens))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.