1

I have a Raspberry Pi 3B+ that I want to make a little home server out of. I decided to start with the current raspbian build, which as of writing was the one released 2019-09-26.

I used Balena Etcher 1.5.57 to create a bootable disk on a 64GB SanDisk microSD card.

Tried to boot the Pi but it fails saying Unable to mount root fs on unkown-block(179,2)

Tried to flash it again which didn't solve the issue and tried using dd. In total I flashed it two or three with etcher and tried to write it with dd once or twice. I don't after which of these operations the disk stopped working as they all appeared to be successful. (When doing this I thought the problem lay in the iso I had downloaded).

Now the problem, after I decided to use NOOBS instead I found out that I can no longer write anything to the SD card! This means I cannot flash another image with etcher and can not modify any partitions on it (tried with gparted and fdisk).

As an example, I can run mkfs.ext4 /deb/sdb1, confirm that I want to format even though it is a boot partition and have the command terminate without any error. When I replug the sd card and run the same command I get the same error and the card still contains the same files as before.

What can I do to make this SD card useable again, ie how can I write to it again?

I tried the solutions proposed in https://askubuntu.com/questions/213889/microsd-card-is-set-to-read-only-state-how-can-i-write-data-on-it but that did not help.

  • 3
    You could try with the official SDFormatter which will attempt to recreate the card but the SD Card is probably dead. – Milliways Oct 8 at 12:32
  • Your SDCard is worn out. Toss it in the bin and replace it with a factory fresh card. – Dougie Oct 8 at 16:52
  • Running dmesg after plugging in the SD card may show that it's stuck read-only, in which case as @Dougie suggests it's probably worn out. – Fred Oct 8 at 20:01
  • What OS are you using to write to the SD card? – ctrl-alt-delor Oct 8 at 21:09
  • @ctrl-alt-delor this is on ubuntu 18.04 – jdoe Oct 9 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.