0

I have tried several ideas such as:

chown pi:pi .Xauthority choxn -R pi /home/pi

and I have deleted .Xauthority

But my pi keeps returning to the Shut-Down / Log-In screen no matter what I do.

I can get to terminal (ctrl-alt-F1) and do what ever I want, but the desktop won't finish loading.

Password is correct and working, just returns to the same screen.

4
  • Check free disk space and check the X log files
    – Dirk
    Oct 8, 2019 at 20:02
  • What kind of Pi are you running and what operating system?
    – Fred
    Oct 8, 2019 at 20:07
  • What have you done that this happen?
    – Ingo
    Oct 9, 2019 at 9:01
  • Rc.local - tried to add a link to a python program, using graphics gui, to run on boot. Problem started after I removed the link. PI 3b Raspbian
    – smclaugh5
    Oct 10, 2019 at 23:22

3 Answers 3

0

I faced a similar problem about 10 days ago. And I had to reinstall the OS. Anything you change or delete related with boot can affect the OS badly. My suggestion is you should re install the OS

2
  • Rc.local - tried to add a link to a python program, using graphics gui, to run on boot. Problem started after I removed the link. PI 3b Raspbian
    – smclaugh5
    Oct 9, 2019 at 21:45
  • disk 16 gb about half full
    – smclaugh5
    Oct 9, 2019 at 21:46
0

There are numerous ways to solve this. Noted that you tried to chown .Xauthority with the -R switch and probably you tried it with a sudo, but again - try this version;

$ sudo chown pi:pi .Xauthority
$ sudo apt-get update & sudo apt-get upgrade
$ sudo reboot

In case that doesn't work, since you have access to the CLI space at [ALT]+[F1], you can always as a resort try to save necessary files by starting desktop with superuser with

$ sudo startx 

Also have a look at for any quirkiness

$ sudo nano /etc/rc.local

at the bottom just above "exit 0" and have a consideration with commenting out a potential line familiar from a recent install with a #

Reinstalling the OS as a solution is seldom necessary, anything can be fixed but in case there isn't any crucial work lost in the process it can be a good time saving option on some occasions.

0

What the OP describes here is an X11 Session Error. A more complete description comes from https://forums.raspberrypi.com/viewtopic.php?p=1219348&sid=a8a57224a0ccc492e7882ba151d5e4b9#p1219348

This is the second time I've had this problem. Last time I gave up and rebuilt from a new download of Raspbian.

Expected functionality: Pi3 (Raspbian, Stretch, up to date) is set to "Boot to desktop". When I turn on I get to the desktop and can do stuff. No password required. I have been using the pi this way since 23rd August with no problems whatsoever.

Symptoms after a reboot today - different to every other reboot I've done:

  1. Through SSH I can log in using default word "raspberry".

  2. When connected to HDMI/keyboard/mouse instead getting to the desktop I get to a login prompt for pi on desktop screen3)

  3. If I enter the correct password "raspberry" I get a black screen and then the login prompt comes back

  4. If I enter an incorrect password deliberately it tells me, correctly, that I got it wrong.

  5. Over SSH I added a new user with useradd, and using that user I can login successfully to the desktop at the login prompt .

  6. Over SSH I changed the password for user pi, however when I try to use that to get to the desktop I get the symptoms in 3 above.

To summarize a few great answers including https://askubuntu.com/a/246858/146273 and https://askubuntu.com/a/223634/146273 ...

  1. Check for .xsession-errors.old and/or .xsession-errors.old in your $HOME folder.
  2. Read them and see if they tell you why your Display Manager has failed to hand off control to an X11 Session.
  3. Be aware that because /etc/X11/Xsession is a shell script that sources many other shell scripts, the error message might not tell you the true file/location of the error, but it will help you discern the true nature of it.

Happy hunting. May the odds be ever in your favor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.