0

Before going ahead what is the problem I am facing let me give you a hint about the Revolution Pi Connect an IIoT device based on Raspberry pi:https://revolution.kunbus.com/tutorials/uebersicht-revpi-connect/.

This RevPi(Revolution Pi) has two ethernet port eth0 and eth1. Now the from wifi router generating IP range 192.168.10.2 to 192.168.10.102 Through DHCP. My system (PC) I have two IP one over Wifi and one over ethernet(static IP set) as shown

Ethernet adapter Ethernet:

 Connection-specific DNS Suffix  . :
 Link-local IPv6 Address . . . . . : fe80::7d8d:1cb5:ec81:51c5%22
 IPv4 Address. . . . . . . . . . . : 192.168.2.59
 Subnet Mask . . . . . . . . . . . : 255.255.255.0
 Default Gateway . . . . . . . . . : 192.168.2.255   


Wireless LAN adapter Wi-Fi:

 Connection-specific DNS Suffix  . :
 Link-local IPv6 Address . . . . . : fe80::ecad:bd0e:738d:e3ac%3
 IPv4 Address. . . . . . . . . . . : 192.168.10.46
 Subnet Mask . . . . . . . . . . . : 255.255.255.0
 Default Gateway . . . . . . . . . : 192.168.10.1  

First port eth0 of RevPi I get the IP from DHCP router as 198.168.10.34. By using this IP I am able to access the RevPi over SSH-Putty. Now for the second port eth1 of RevPi, I set static IP as 198.168.2.254 using this:How do I set up networking/WiFi/static IP address?

so I set up as:

interface eth1
static ip_address=192.168.2.254/24
static routers=192.168.10.1
static domain_name_servers=192.168.10.1

So now I am able to ping from my system(PC) which has static IP over ethernet as 198.168.2.59 to RevPi(Revolution Pi Connect) but Unable to ping from the Revolution Pi Connect (Raspberry pi based IIoT device) to PC? please help me to resolve this. Thanks in advance.

 traceroute to 198.168.2.59 (198.168.2.59), 30 hops max, 60 byte packets

 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
 10  * * *
 11  * * 69.77.173.2 (69.77.173.2)  211.588 ms
 12  * * *
 13  * * *
 14  * * *
 15  * * *
 16  * * *
 17  * * *
 18  * * *
 19  * * *
 20  * * *
 21  * * *
 22  * * *
  • You have incompletely followed a tutorial without understanding routing (incidentally ignoring the warning setting up a static address is NOT recommended). You probably have setup an impossible routing situation, but have not provided sufficient information for anyone to make sense of your problem. At the least the output of ip r would at least provide a start, but far more detail is required. – Milliways Oct 9 '19 at 10:56
  • @Milliways kindly please tell me what extra detail I should include making sense to everyone and I want to set static IP so I can communicate with my slave(software on my system ) over ethernet. I am in my learning stage of computer networking if you want to help please help me. – anil Oct 9 '19 at 11:41
  • Milliways wrote: At the least the output of ip r would at least provide a start. Edit your question and paste it into it. – Ingo Oct 9 '19 at 22:19
  • @Milliways sir, I added the ip r .One more thing now even I am not able to ping from my system to RevPi which was ok earlier. – anil Oct 10 '19 at 6:29
  • @Milliways I had the answer to my question. So I think was making a mistake to set the DNS server IP. – anil Dec 14 '19 at 10:44
0

First I will explain my system IP settings as shown below, in which the IP for wireless LAN has opted from wifi router generating IP range 192.168.10.2 to 192.168.10.102 Through DHCP. The IP for the Ethernet adapter side I opted from system administrator as static IP 192.168.1.59. with the DNS as 8.8.8.8and alternative DNS4.2.2.2

  Ethernet adapter Ethernet:

  Connection-specific DNS Suffix  . :
  Link-local IPv6 Address . . . . . : fe80::7d8d:1cb5:ec81:51c5%18
  IPv4 Address. . . . . . . . . . . : 192.168.1.59
  Subnet Mask . . . . . . . . . . . : 255.255.255.0
  Default Gateway . . . . . . . . . : 192.168.1.254  

  Wireless LAN adapter Wi-Fi:

  Connection-specific DNS Suffix  . :
  Link-local IPv6 Address . . . . . : fe80::ecad:bd0e:738d:e3ac%3
  IPv4 Address. . . . . . . . . . . : 192.168.10.98
  Subnet Mask . . . . . . . . . . . : 255.255.255.0
  Default Gateway . . . . . . . . . : 192.168.10.1

Now come to Revolution Pi which has two ethernet port eth0 and eth1. First port eth0 of RevPi I get the IP from DHCP router as 198.168.10.71. By using this IP I am able to access the RevPi over SSH-Putty. Now for the second port eth1 of RevPi, I set static IP as 198.168.1.222(Free IP is taken from system admin) using this:How do I set up networking/WiFi/static IP address?

  interface eth1
  static ip_address=192.168.1.222/24
  static routers=192.168.1.1
  static domain_name_servers= 4.2.2.2

Now I am able to communicate (ping) from both ways i.e. from (1) From my system(PC) to both port of RevPi(Revolution Pi)as

  C:\Users\SAMRUDDHI>ping 192.168.1.222

  Pinging 192.168.1.222 with 32 bytes of data:
  Reply from 192.168.1.222: bytes=32 time=1ms TTL=64
  Reply from 192.168.1.222: bytes=32 time<1ms TTL=64
  Reply from 192.168.1.222: bytes=32 time<1ms TTL=64
  Reply from 192.168.1.222: bytes=32 time<1ms TTL=64

  Ping statistics for 192.168.1.222:
  Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
  Approximate round trip times in milli-seconds:
  Minimum = 0ms, Maximum = 1ms, Average = 0ms

  C:\Users\SAMRUDDHI>ping 192.168.10.71

  Pinging 192.168.10.71 with 32 bytes of data:
  Reply from 192.168.10.71: bytes=32 time=3ms TTL=64
  Reply from 192.168.10.71: bytes=32 time=1ms TTL=64
  Reply from 192.168.10.71: bytes=32 time=1ms TTL=64
  Reply from 192.168.10.71: bytes=32 time=3ms TTL=64

  Ping statistics for 192.168.10.71:
  Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
  Approximate round trip times in milli-seconds:
  Minimum = 1ms, Maximum = 3ms, Average = 2ms

(2)RevPi(Revolution Pi) to the system(PC) by opening terminal with any one of the port IP among the eth0 and eth1 of RevPi(Revolution Pi). enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.