1

I followed the installation instructions listed for the Raspberry Pi version of Rocket Chat on Github. The software installs properly. However, I am having an issue enabling HTTPS using caddy. The instructions state that I have to run the following commands:

sudo snap set rocketchat-server caddy-url=https://<your-domain-name>
sudo snap set rocketchat-server caddy=enable 
sudo snap set rocketchat-server https=enable sudo rocketchat-server.initcaddy

When running the third command, I get this error:

error: cannot perform the following tasks:
- Run configure hook of "rocketchat-server" snap (run hook "configure":
-----
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
dig: error while loading shared libraries: libdns.so.162: cannot open shared object file: No such file or directory
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
Error: Can't resolve DNS query for <your-domain-name>, check your DNS configuration, disabling https . . .
-----)

Note:

  • Wherever the code says "your-domain-name" I did actually put my real domain name in.

  • I am using a Raspberry Pi Model 4, 4GB with a fresh installation of
    the July 10th version of Raspbian Buster Lite.

  • I am using GoDaddy with an A record to link my domain name to my
    router's public IP.

  • Port 80 and Port 443 are open on my router. I have enabled port
    forwarding. If I open port 3000 on my router, I am able to access
    Rocket from :3000. However, this does not enable https, which is what I would like. My pi does have a static IP set up for it

Does anyone have an idea of what to do? Unsure if anyone else has experienced this issue.

1

After a bit of Googling, according to an IPFS GitHub issue, it looks like the 'libarmmem' error is misleading here and can be ignored. If you'd like that message to go away edit /etc/ld.so.preload and comment out the line containing 'libarmmem' (i.e. add a # to the beginning of the line).

It looks like the real underlying error is with DNS:

dig: error while loading shared libraries: libdns.so.162: cannot open shared object file: No such file or directory
Error: Can't resolve DNS query for <your-domain-name>, check your DNS configuration, disabling https . . .

This sort of error of missing libraries is usually fixed by reinstalling the relevant package. In this case that should be dnsutils. To reinstall:

sudo apt-get update
sudo apt-get install --reinstall dnsutils

If that still doesn't fix it, this Reddit post on PiHole suggests either re-flashing or changing to a new SD card.

3
  • Thanks for the suggestion and sorry for the delay. I tried the different approaches. However, the same error message pops up. Maybe it's an issue with Raspbian Buster Lite? I've tried reinstalling dnsutils, I've tried reflashing the SD card, I've also tried using another SD card. Nothing seems to fix the issue. Really stumped on this one. – Cashew Oct 14 '19 at 2:18
  • I did some digging and I found this link regarding issues with rocketchat and dig. forum.snapcraft.io/t/… I am unsure what the equivalent fix for Raspbian would be. – Cashew Oct 14 '19 at 2:34
  • One of the final comments on that thread suggests the dig error is a build issue, in which case you'll need to file a bug report with Rocket Chat at rocket.chat/docs/contributing/reporting-issues. – Fred Oct 14 '19 at 6:25
0

Remove snap version of caddy.

sudo snap set rocketchat-server caddy=disable

And then follow this guide to install caddy separately.

Then edit /etc/caddy/Caddyfile keeping just the following contents:

your.domain.com
reverse_proxy 127.0.0.1:3000

Finally

systemctl restart caddy
New contributor
Jannis Ioannou is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.