2

I just bought a Raspberry Pi model 4B. I am trying to set the video output to 4k resolution and 60Hz refresh rate. While I am able to have the output running at 4k resolution (3840x2160 pixels), I am only able to have a refresh rate of 30 Hz. I am unable to set 60Hz output refresh rate. Whenever I try to activate 60Hz through the display settings, my screen turns black and there is a popup message (notification from my On-Screen-Display of the manufacturer of the screen), saying that there is no input signal. After 10 seconds, Raspi 4B reverts to the previous screen settings, which were 4k@30Hz, and the screen is active again.

What I have tried so far: 1.) Run the following command: sudo sh -c "echo hdmi_enable_4kp60=1 >> /boot/config.txt" ... after running this, I was able to select 60Hz in the Display settings. But I am unable to get a signal on my screen with 60Hz.

2.) Run the following command: sudo raspi-config -> Advanced options -> Pi 4 Video Output -> Enable 4Kp60 HDMI And also: sudo raspi-config -> Advanced options -> Pi 4 Video output -> Memory Split -> set to 256MB VRAM (also tried 512MB VRAM, no luck however)

How can I enable 60Hz refresh rate?

Hardware I use: -> Raspberry Pi Model 4B -> Official Raspberry Pi 4 Mini-HDMI to HDMI cable (it says High Speed HDMI cable with Ethernet on the cable itself, so this should be fine?) -> LG 27UK650-W (4k display)

I am thankful for any advice you might have for me.

edit from Oct 13rd, 2019, 20:52UTC:

Today I had some more time to test some stuff. I am able to get a 4k 60 Hz video signal from my Pi 4 on some occasions. I have to replug the HDMI cable into my Pi 4B several times in order to get a signal. I always use HDMI0 (the left mini HDMI connector). I am investigating the behavior on my Pi4 (connected to my computer screen) and at the same time, I use VNC to see whether the Pi is active and running.

During boot sequence I always get a picture with a black screen and the 4 raspberries in the top left corner with 4k resolution. While the Pi 4 continues to boot I always see the desktop via VNC, but my computer screen says 'No signal found' as soon as the Pi 4B is at the desktop. Sometimes replugging the HDMI cable into the Pi 4B helps and I get a 4k@60Hz signal on my screen, but most times I do not get a signal.

I do not know why sometimes it works and other times it does not.

Half an hour ago I went AFK for a while and came back. While the Pi 4B was still running (as I could use it via VNC), my screen just shows a black picture and I do not see the desktop, it just is a plain black image. Yet there was no message on my screen saying that there is no signal, it appears that the Pi 4B just sent a black screen. I had to plug in the HDMI cable several times in order to see the desktop again at 4k and 60Hz.

What I tried by now (additionally to the aforementioned stuff from my original post):

1.) in /boot/config.txt, I activated hdmi_force_hotplug=1 , but this did not solve the problem and there was no signal being sent from the Pi 4B to my computer screen after reboot, as soon as the Pi is on desktop (according to VNC).

2.) in /boot/config.txt, I activated config_hdmi_boost=4 , also tried to set the value to 6 and 9, but it did not solve the problem and there was no signal being sent from the Pi 4B to my computer screen after reboot, as soon as the Pi is on desktop (according to VNC).

3.) tvservice -s state 0xa [HDMI CUSTOM RGB lim 16:9], 3840x2160 @ 60.00Hz, progressive

4.) tvservice -l 1 attached device(s), display ID's are : Display Number 2, type HDMI 0

Note that tvservice -s and tvservice -l show the same output even when I do not connect the Pi 4B to my screen! (is that normal?)

Right now as I am typing this message, it seems the Pi 4B video output just goes crazy. The Pi 4B is responsive via VNC, CPU and GPU temperatures are around 70°C. My computer screen just went black, a few seconds later there was a message appearing, stating "No input signal", screen turns off (energy saving mode), a few seconds later without touching anything, my screen is receiving a signal again and I see a black picture (on VNC, I still see my desktop). This repeated like 5 times. The red LED on the Pi went off and on at random moments (it was not blinking regularly). Now the Pi just turned itself off, I cannot ping him on my network, the power connector is still plugged in but there is no light coming from the LED.

I plugged in my power cable several times, the Pi 4B is not booting, the LED is not going. On the 7th time, the Pi is booting up again.

3

If you are unable to see video signal and unable to connect RPi4 via VNC and SSH, I would try to connect the SD card to computer and reset /boot/config.txt back to default or use second SD card with default OS and screen settings to see if that help to make RPi booting and sending a video signal.

Regarding 4K (UHD) not working, check the following things:

  1. power adaptor: I assume you are using the power adaptor provided by the RPi manufacturer. I am using a powerful one - 4A, 5V. I am not sure if disconnecting USB peripherals can allow RPi to use more power.

  2. temperature: I think that You should have heatsink if you plan to play 4K to make sure the chip temperature stays below 85°C during playback:

    echo CPU: $(cat /sys/class/thermal/thermal_zone0/temp|cut -b -2)°
    
  3. Interface vs video itself: It can be possible that some operating systems interfaces are not made to support 4K display, yet it plays the 4K videos.

  4. HDMI port support: Not all HDMI ports on TV may support 4K. On RPi4 I am aware only one port support it by default - one closer to power supply port.

  5. HDMI cable support: verify your HDMI cable is able to transfer 4K by connecting it to a different device like your desktop computer

  6. Enable UHD/4K in RPi4: By adding new line "hdmi_enable_4kp60=1" to /boot/config.txt or using command:

    sudo raspi-config
    
    • Advanced Options –> (A9) Pi 4 Video Output
    • Advanced Options –> (A5) Resolution.

For 4K(UHD) videos RPi4B hardware supports only H265(HEVC) codec. VP9 or H264 not worked for me (too lagging even the CPU overall did not appear overloaded)

0

Do you have Fake KMS enabled in /boot/config.txt? Which means, do you have this line

dtoverlay=vc4-fkms-v3d

in your config.txt?

If yes, we probably have the same issue that Fake KMS and 4K60 cannot co-exist.

I figured out a way to fix my issue. Hope it could also help you.

Step 1. Disable 4K60 and Enable VNC and SSH.

Disable 4K60, and now you should be able to see your screen. Enable VNC. Change the authentication from UNIX password to VNC password. Enable SSH, in case you missed something, you do not have to take out the micro SD card.

Step 2. Enable 4K60 and Connect via VNC.

Add hdmi_enable_4kp60=1 in your /boot/config.txt . However, adding that would make VNC unusable. To make VNC usable, we need to manually add these two lines:

hdmi_group=1
hdmi_mode=95

Without hdmi_group=1 and hdmi_mode=95, the VNC connection will say something like Cannot currently show the desktop. Some other numbers may work as well, but I have not tested. BTW, Mode 95 is 4K30.

Now you should be able to connect to your Pi via VNC.

Step 3. Set Correct Refresh Rate.

Go to Preferences -> Screen Configurations and you will see that your monitor is probably set to an uncommon refresh rate. In my situation, Pi set my monitor to 59.98Hz, which is not supported. Setting refresh rate to either 59.94Hz or 60.00Hz would solve the issue.

Now you should be able to see graphics on your monitor.

Step 4. Change config.txt Again.

Now, TTY1 to TTY6 are still missing. If I switch to TTY by Ctrl+Alt+F1 to F6, there will be no signal. My solution is to change config.txt again:

hdmi_group=1
hdmi_mode=16

This time, Mode 16 is 1080p60. You may use something else like Mode 4 for 720p60. As long as it’s not 4K, it should work.

After restart, TTY are working fine in 1080p60, while the desktop is working fine in 4K60. Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.