I am currently attempting to set up PPP between my Pi and my Ubuntu 13.04 Toshiba Satellite A105 via the Serial Cable, as per this site: http://elinux.org/RPi_Serial_Connection.

I successfully (I think) started PPP Daemon on my pi via sudo pppd it worked for a second then gave me this:

pppd: The remote system is required to authenticate itself
pppd: but I couldn't find any suitable secret (password) for it to use to do so.

I ignored this because of the RPi Serial Connection page it says:

Step 1: login to the Raspberry Pi over the serial cable and run the Point-to- Point Protocol Daemon:
sudo pppd
Some garbage will start appearing in the terminal. This is the cue to quit your terminal program and proceed to step two.

So I did this and then proceeded on to step two. This is where my problem begins (I think.)

I started another terminal for connecting to my Pi and entered the command given to me in step two: sudo pppd -detach noauth proxyarp /dev/ttyUSB0 115200 10.0.0.1:10.0.0.2 passive local maxfail 0 nocrtscts xonxoff

This is where I have trouble. It tells me this:

nate@excelion-Satellite-A105:~$ :~$ sudo p-detach noauth proxyarp /dev/ttyUSB0-0 115200 10.0.0.1:10.0.0.2 passive local maxfail 0 nocrtscts xonxoff
[sudo] password for nate: 
pppd: unrecognized option '/dev/ttyUSB0-0'
pppd version 2.4.5
Usage: pppd [ options ], where options are:
    <device>    Communicate over the named device
    <speed>     Set the baud rate to <speed>
    <loc>:<rem> Set the local and/or remote interface IP
            addresses.  Either one may be omitted.
    asyncmap <n>    Set the desired async map to hex <n>
    auth        Require authentication from peer
        connect <p>     Invoke shell command <p> to set up the serial line
    crtscts     Use hardware RTS/CTS flow control
    defaultroute    Add default route through interface
    file <f>    Take options from file <f>
    modem       Use modem control lines
    mru <n>     Set MRU value to <n> for negotiation
See pppd(8) for more options.

What am I doing wrong? My Ubuntu system is totally up to date (just ran apt-get upgrade last night) and I just installed ppp onto my Pi about 20 minutes ago ( as of 2:30 10/31/2013)

Thanks!

please, look carefully at your command line, I don't believe there's a device called /dev/ttyUSB0-0 in your system, you should have -0 part separated from the file name or removed altogether.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.