0

I am trying to run snips on my rpi0w, and has mounted the respeaker pi hat on to it.

Installed the driver using

git clone https://github.com/respeaker/seeed-voicecard
cd seeed-voicecard
sudo ./install.sh 
sudo reboot

I disabled the cdmi audio setting in the boot/config such that it only finds the respeaker pi hat 2

pi@raspberrypi:~/seeed-voicecard $ aplay -l && arecord -l
**** List of PLAYBACK Hardware Devices ****
card 0: seeed2micvoicec [seeed-2mic-voicecard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**** List of CAPTURE Hardware Devices ****
card 0: seeed2micvoicec [seeed-2mic-voicecard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and my sound.conf looks like this

pi@raspberrypi:~/seeed-voicecard $ cat  /etc/asound.conf
# The IPC key of dmix or dsnoop plugin must be unique
# If 555555 or 666666 is used by other processes, use another one


# use samplerate to resample as speexdsp resample is bad
defaults.pcm.rate_converter "samplerate"

pcm.!default {
    type asym
    playback.pcm "playback"
    capture.pcm "capture"
}

pcm.playback {
    type plug
    slave.pcm "dmixed"
}

pcm.capture {
    type plug
    slave.pcm "array"
}

pcm.dmixed {
    type dmix
    slave.pcm "hw:seeed2micvoicec"
    ipc_key 555555 
}

pcm.array {
    type dsnoop
    slave {
        pcm "hw:seeed2micvoicec"
        channels 2
    }
    ipc_key 666666
}

problems is that when i test it by simple recording something, and play the same file

arecord -d 5 /tmp/test-mic.wav && aplay /tmp/test-mic.wav

The only thing I hear is noise? Its as if nothing gets recorded, or not played correctly?

do I have some malfunctioning hardware, or is the config wrong?

Why am not able to play audio and record audio using the respeaker pi hat 2?

0

Try using "sam" - , it works like a charm

apt-get install sam
sam connect localhost
sam setup audio

You should be abale to install it if you made the regular setup with snips

  • speaker-test still outputs noise.. – I am not Fat Oct 13 at 15:19
  • if you did the audio setup with sam , all settings should be fine (check /etc/asound.conf again) - so it looks like a defective respeaker2 or defective speaker itself ... can you check another speaker or that speaker anywhere else ? – DocYester Oct 13 at 17:57
  • i tried with different hw no change – I am not Fat Oct 13 at 21:51
  • I have it on headphones, i assume that sam test only outputs on speaker, hence i am not able to get an output. speaker-test still gives noise – I am not Fat Oct 13 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.