0

We've setup and successfully used several Rasberry Pi's to connect via Wi-Fi to a cell phone hot spot to grab UTC for the app the Pi is running. This has been working for over 2 years at locations around the world (China, Greece, Portugal, USA...), and has worked solid with both an iPhone and an Android phone.

Now in Seoul S. Korea, we're experiencing a very odd behavior. The same Android phone as above still works, but now the same iPhone as above does not. Further more, we tried several other iPhones and Android phones and none of those work either.

We've tried this using both a pwd for wpa and none, with the same result.

One difference between the single Androidphone that works and all the other Android phones and iPhones that don't work is that the Android phone that does work is on Google Fi, where as all the others are T-Mbbile, Verizon, etc. Best we can though is they're all connected for KTS here in Seoul.

One additional thing we tried was connecting a Wi-Fi receiver to one of the Android phones that did not work above. That was then connect by a (ethernet) cable to a Wi-Fi router and then was able to connect the Pis to the router. In this case it appears that some security or carrier restrictions are imposed to devices directly connected to the phone and now that the Rasberry Pi is not directly connected to the phone, whatever issue is occurring is being circumvented.

Was wondering if there is something we could do differently, maybe add to the wpa_supplicant.conf file that would make this work. Currently it contains:

network={
ssid="ssidname"
psk="hpassword"
key_mgmt=WPA-PSK
} 

or

network={    
ssid="ssidname"    
key_mgmt=NONE    
}

Has anyone else seen this issue or one similar to it, either in S Korea or elsewhere?

Is this a country thing?

Is this a regional carrier thing?

Is it related to security?

Update - I had a couple guys look at this today to see if they could determine where things go wrong. The pi's initially see the hot spot for one of the phones from above that did not work as well as other networks, but it could not connect to the hot spot. Sometime shortly afterwards it does not even see the hot spot or other networks.

  • What do you expect to do with Raspberry Pi to fix the problem? – Ingo Oct 14 at 9:23
  • Please add the info from the comment to your question. You can edit it. – Ingo Oct 14 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.