0

I am trying to build a Raspberry Pi kernel by cross-compiling on an Ubuntu 18.04 LTS instance. The compilation of zImage, modules, and dtbs all complete as expected.

However, when I run the make module_install:

sudo env PATH=$PATH make modules_install ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- INSTALL_MOD_PATH=temppath/ext4 

and then ls in temppath/ext4, the directory is empty.

The same thing happens when I run:

sudo env PATH=$PATH make dtbs_install ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- INSTALL_MOD_PATH=temppath/fat32 

the temppath/fat32 directory is empty.

Both modules_install and dtbs_install provide command line output similar to this:

  ...
  INSTALL sound/soc/codecs/snd-soc-i-sabre-codec.ko
  INSTALL sound/soc/codecs/snd-soc-ics43432.ko
  INSTALL sound/soc/codecs/snd-soc-pcm1794a.ko
  INSTALL sound/soc/codecs/snd-soc-pcm186x-i2c.ko
  INSTALL sound/soc/codecs/snd-soc-pcm186x.ko
  INSTALL sound/soc/codecs/snd-soc-pcm5102a.ko
  INSTALL sound/soc/codecs/snd-soc-pcm512x-i2c.ko
  INSTALL sound/soc/codecs/snd-soc-pcm512x.ko
  INSTALL sound/soc/codecs/snd-soc-sgtl5000.ko
  INSTALL sound/soc/codecs/snd-soc-sigmadsp-i2c.ko
  INSTALL sound/soc/codecs/snd-soc-sigmadsp.ko
  INSTALL sound/soc/codecs/snd-soc-spdif-rx.ko
  INSTALL sound/soc/codecs/snd-soc-spdif-tx.ko
  INSTALL sound/soc/codecs/snd-soc-tas5713.ko
  INSTALL sound/soc/codecs/snd-soc-tlv320aic32x4-i2c.ko
  INSTALL sound/soc/codecs/snd-soc-tlv320aic32x4.ko
  ...

However, no files are created.

Any ideas out there?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.