1

I was installing different DEs like KDE Plasma and Cinnamon on Rasbian buster. I uninstalled KDE and I’m using Cinnamon as my permanent DE, but somehow KDE reconfigured xserver so that even now with only pixel and Cinnamon installed, it boots into CLI mode and I have to run ‘startx’ every time I want the GUI, which I use 95% of the time. I have repeatedly ran ‘raspi-config’ and set it to boot into GUI with manual log-in but to no avail.

Basically I think KDE installed something called ‘sbbm’ instead of lightDM when it was installed. I think that that might have caused a issue.

Someone on a discord sent me a link on how to fix it, but I can’t find the link and all my previous searches don’t yield even close results, so I’m asking here.

TL;DR How to set xserver to automatically start again?

  • Seeing as we don't know what you did we can't say. Restore from your backup. – Milliways Oct 17 at 3:32
  • No backups. But I edited the question. – lockheed silverman Oct 17 at 3:33
  • 1
    This isn't an xserver configuration problem, it's (as you suspect) a display manager (DM, as in lightDM etc) problem. The DM is independent of the DE, but DE's often install their choice of DM. Right now it sounds like you do not have one running, or the one that's configured to run (via systemd, not the xserver) isn't installed, or something. Generally speaking, unless you have good reason, don't uninstall software when you want to use something else in its place. Just install what you want to use and use it instead. Uninstalling something is no guarantee of "going back to how it was". – goldilocks Oct 17 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.