1

I have been using Raspi as a local Django server for a few months now. One day, when I came back from work the local server was not working anymore so I decided to unplug and plug back the power.

Since then, I have not been able to complete the boot of the Raspi. It hangs at:

Boot: Started Update UTMP about System Boot/Shutdown

see photo below enter image description here

Find herebelow my config file:

# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
dtparam=spi=on
enable_uart=1
# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
dtoverlay=tft35a
#dtoverlay=ads7846,cs=1,penirq=17,penirq_pull=2,speed=1000000,keep_vref_on=1,swapxy=1,pmax=255,xohms=60,xmin=200,xmax=3900,ymin=200,ymax=3900

#display_rotate=2
startx=0

I added the startx=0 to see if there was any difference but no.

Here is how my cmdline looks:

dwc_otg.lpm_enable=0 console=tty1 console=ttyAMA0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait fbcon=map:10 fbcon=font:ProFont6x11 logo.nologo

Any suggestions?

  • Remove quiet from /boot/cmdline.txt and try again. Please don't post logs as screenshots, especially if the error message isn't in them. Consider how long it will take you to start from scratch (or from a backup), maybe losing several hours debugging the system isn't worth it. – Dmitry Grigoryev Oct 17 at 9:27
  • 1
    Thanks @DmitryGrigoryev! There is no quiet on my cmdline.txt. Alright, no future images. Any other ideas? – Alvaro Oct 17 at 9:38
  • 1
    Check the root FS with fsck on a working system to be sure it's clean. Next, set up persistent kernel log by settingStorage=persistent in /etc/systemd/journald.conf and browse through logs in /var/log/journal after a reboot. Assuming you have access to the roof FS of course. – Dmitry Grigoryev Oct 17 at 11:01
  • Ditto that you have to run fsck on the root filesystem before you can debug this further. – goldilocks Oct 17 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.