0

I'm running into a recurring issue and I can't seem to find a resolution for it that works.

Pi info:

Linux version 4.19.79-v7+ (dom@buildbot) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611)) #1273 SMP Fri Oct 11 18:13:16 BST 2019
Chromium 72.0.3626.121 Built on Raspbian , running on Raspbian 9.11

Context The pi is used to run Chromium in Kiosk mode with only a mouse, display and internet.

Initially, I blamed the web page I was displaying. I've spent a lot of time rewriting the front-end code that powers the screen looking for and fixing memory leaks etc.

The problem is, when running it on this Pi I run into the Aw Snap page regularly and not at fixed intervals. However, when I run it on my development machine, I never seem to hit this page. This is what led me to investigate the memory usage of the page as the Pi has significantly less RAM and storage to play with.

Any suggestions or tips would be greatly appreciated, and if anyone else has managed to resolve this issue I'd love to hear your solution.

  • You should monitor the RAM usage to confirm whether that is the problem. – goldilocks Oct 17 '19 at 15:40
  • The latest version of Chromium for Raspbian Buster is v74. Either you are still running Stretch, of this means you haven't updated in a while. Just run sudo apt update&&sudo apt full-upgrade -y – Botspot Oct 23 '19 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.