1

I am running a raspberry Pi 2B (with GUI disabled) and I added deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi to my sources.list.

After this, I ran sudo apt-get update and everything seems to work.

But when I executed sudo apt-get upgrade, a few packages could not be installed.

sudo dpkg --configure -a did not help(same errors), and because of that, I decided to comment my source out again.

That didn't help, I got the same errors:

Reading package lists...
Building dependency tree...
Reading state information...
The following packages have been kept back:
  opensc opensc-pkcs11
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
43 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Setting up console-setup-linux (1.193~deb10u1) ...
insserv: FATAL: service udev is missed in the runlevels 2 3 4 5 to use service raspi-config
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package console-setup-linux (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of console-setup:
 console-setup depends on console-setup-linux | console-setup-freebsd | hurd; however:
  Package console-setup-linux is not configured yet.
  Package console-setup-freebsd is not installed.
  Package hurd is not installed.

dpkg: error processing package console-setup (--configure):
 dependency problems - leaving unconfigured
Setting up cups-daemon (1.7.5-11+deb8u6) ...
insserv: FATAL: service udev is missed in the runlevels 2 3 4 5 to use service raspi-config
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package cups-daemon (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up netfilter-persistent (1.0.11) ...
insserv: FATAL: service udev is missed in the runlevels 2 3 4 5 to use service raspi-config
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package netfilter-persistent (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of iptables-persistent:
 iptables-persistent depends on netfilter-persistent (= 1.0.11); however:
  Package netfilter-persistent is not configured yet.

dpkg: error processing package iptables-persistent (--configure):
 dependency problems - leaving unconfigured
Setting up rsyslog (8.4.2-1+deb8u3) ...
insserv: FATAL: service udev is missed in the runlevels 2 3 4 5 to use service raspi-config
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package rsyslog (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up binfmt-support (2.2.0-2) ...
insserv: FATAL: service udev is missed in the runlevels 2 3 4 5 to use service raspi-config
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package binfmt-support (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up x11-common (1:7.7+19) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
insserv: FATAL: service udev is missed in the runlevels 2 3 4 5 to use service raspi-config
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package x11-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libxss1:armhf:
 libxss1:armhf depends on x11-common; however:
  Package x11-common is not configured yet.

dpkg: error processing package libxss1:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libtk8.6:armhf:
 libtk8.6:armhf depends on libxss1; however:
  Package libxss1:armhf is not configured yet.

dpkg: error processing package libtk8.6:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of tk8.6-blt2.5:
 tk8.6-blt2.5 depends on libtk8.6 (>= 8.6.0); however:
  Package libtk8.6:armhf is not configured yet.

dpkg: error processing package tk8.6-blt2.5 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of blt:
 blt depends on tk8.6-blt2.5 (= 2.5.3+dfsg-4); however:
  Package tk8.6-blt2.5 is not configured yet.

dpkg: error processing package blt (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups-core-drivers:
 cups-core-drivers depends on cups-daemon (>= 1.7.5-11+deb8u6); however:
  Package cups-daemon is not configured yet.

dpkg: error processing package cups-core-drivers (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups:
 cups depends on cups-core-drivers (>= 1.7.5-11+deb8u6); however:
  Package cups-core-drivers is not configured yet.
 cups depends on cups-daemon (>= 1.7.5-11+deb8u6); however:
  Package cups-daemon is not configured yet.

dpkg: error processing package cups (--configure):
 dependency problems - leaving unconfigured
Setting up dphys-swapfile (20100506-5) ...
insserv: FATAL: service udev is missed in the runlevels 2 3 4 5 to use service raspi-config
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package dphys-swapfile (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of xfonts-utils:
 xfonts-utils depends on x11-common; however:
  Package x11-common is not configured yet.

dpkg: error processing package xfonts-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gsfonts-x11:
 gsfonts-x11 depends on xfonts-utils (>= 1:7.5+2); however:
  Package xfonts-utils is not configured yet.

dpkg: error processing package gsfonts-x11 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-tk:
 python-tk depends on blt (>= 2.4z-9); however:
  Package blt is not configured yet.
 python-tk depends on libtk8.6 (>= 8.6.0); however:
  Package libtk8.6:armhf is not configured yet.
 python-tk depends on tk8.6-blt2.5 (>= 2.5.3); however:
  Package tk8.6-blt2.5 is not configured yet.

dpkg: error processing package python-tk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of idle-python2.7:
 idle-python2.7 depends on python-tk (>= 2.6~a3); however:
  Package python-tk is not configured yet.
 idle-python2.7 depends on python2.7-tk; however:
  Package python2.7-tk is not installed.
  Package python-tk which provides python2.7-tk is not configured yet.

dpkg: error processing package idle-python2.7 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of jarwrapper:
 jarwrapper depends on binfmt-support; however:
  Package binfmt-support is not configured yet.

dpkg: error processing package jarwrapper (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libice6:armhf:
 libice6:armhf depends on x11-common; however:
  Package x11-common is not configured yet.

dpkg: error processing package libice6:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsm6:armhf:
 libsm6:armhf depends on libice6 (>= 1:1.0.0); however:
  Package libice6:armhf is not configured yet.

dpkg: error processing package libsm6:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxt6:armhf:
 libxt6:armhf depends on libice6 (>= 1:1.0.0); however:
  Package libice6:armhf is not configured yet.
 libxt6:armhf depends on libsm6; however:
  Package libsm6:armhf is not configured yet.

dpkg: error processing package libxt6:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxmu6:armhf:
 libxmu6:armhf depends on libxt6; however:
  Package libxt6:armhf is not configured yet.

dpkg: error processing package libxmu6:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxaw7:armhf:
 libxaw7:armhf depends on libxmu6; however:
  Package libxmu6:armhf is not configured yet.
 libxaw7:armhf depends on libxt6; however:
  Package libxt6:armhf is not configured yet.

dpkg: error processing package libxaw7:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxtst6:armhf:
 libxtst6:armhf depends on x11-common; however:
  Package x11-common is not configured yet.

dpkg: error processing package libxtst6:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of x11-utils:
 x11-utils depends on libxaw7; however:
  Package libxaw7:armhf is not configured yet.
 x11-utils depends on libxmu6; however:
  Package libxmu6:armhf is not configured yet.
 x11-utils depends on libxt6 (>= 1:1.1.0); however:
  Package libxt6:armhf is not configured yet.
 x11-utils depends on libxtst6; however:
  Package libxtst6:armhf is not configured yet.

dpkg: error processing package x11-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libatk-wrapper-java:
 libatk-wrapper-java depends on x11-utils; however:
  Package x11-utils is not configured yet.

dpkg: error processing package libatk-wrapper-java (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libaudio2:armhf:
 libaudio2:armhf depends on libxt6; however:
  Package libxt6:armhf is not configured yet.

dpkg: error processing package libaudio2:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libbonoboui2-0:armhf:
 libbonoboui2-0:armhf depends on libice6 (>= 1:1.0.0); however:
  Package libice6:armhf is not configured yet.
 libbonoboui2-0:armhf depends on libsm6; however:
  Package libsm6:armhf is not configured yet.

dpkg: error processing package libbonoboui2-0:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtkglext1:armhf:
 libgtkglext1:armhf depends on libice6 (>= 1:1.0.0); however:
  Package libice6:armhf is not configured yet.
 libgtkglext1:armhf depends on libsm6; however:
  Package libsm6:armhf is not configured yet.
 libgtkglext1:armhf depends on libxmu6; however:
  Package libxmu6:armhf is not configured yet.
 libgtkglext1:armhf depends on libxt6; however:
  Package libxt6:armhf is not configured yet.

dpkg: error processing package libgtkglext1:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of x11-xkb-utils:
 x11-xkb-utils depends on libxaw7; however:
  Package libxaw7:armhf is not configured yet.
 x11-xkb-utils depends on libxt6; however:
  Package libxt6:armhf is not configured yet.

dpkg: error processing package x11-xkb-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxklavier16:armhf:
 libxklavier16:armhf depends on x11-xkb-utils; however:
  Package x11-xkb-utils is not configured yet.

dpkg: error processing package libxklavier16:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of liblightdm-gobject-1-0:armhf:
 liblightdm-gobject-1-0:armhf depends on libxklavier16 (>= 5.0); however:
  Package libxklavier16:armhf is not configured yet.

dpkg: error processing package liblightdm-gobject-1-0:armhf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sat4j:
 sat4j depends on jarwrapper (>= 0.5); however:
  Package jarwrapper is not configured yet.

dpkg: error processing package sat4j (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-common:
 xserver-common depends on x11-common; however:
  Package x11-common is not configured yet.
 xserver-common depends on x11-xkb-utils; however:
  Package x11-xkb-utils is not configured yet.

dpkg: error processing package xserver-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of tightvncserver:
 tightvncserver depends on x11-common | xserver-common; however:
  Package x11-common is not configured yet.
  Package xserver-common is not configured yet.
 tightvncserver depends on x11-utils; however:
  Package x11-utils is not configured yet.

dpkg: error processing package tightvncserver (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of x2x:
 x2x depends on libxtst6; however:
  Package libxtst6:armhf is not configured yet.

dpkg: error processing package x2x (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfonts-100dpi:
 xfonts-100dpi depends on xfonts-utils (>= 1:7.5+2); however:
  Package xfonts-utils is not configured yet.

dpkg: error processing package xfonts-100dpi (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xfonts-base:
 xfonts-base depends on xfonts-utils (>= 1:7.5+2); however:
  Package xfonts-utils is not configured yet.

dpkg: error processing package xfonts-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xinit:
 xinit depends on x11-common; however:
  Package x11-common is not configured yet.

dpkg: error processing package xinit (--configure):
 dependency problems - leaving unconfigured
Setting up fake-hwclock (0.11) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
insserv: FATAL: service udev is missed in the runlevels 2 3 4 5 to use service raspi-config
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package fake-hwclock (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up triggerhappy (0.5.0-1) ...
insserv: FATAL: service udev is missed in the runlevels 2 3 4 5 to use service raspi-config
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package triggerhappy (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 console-setup-linux
 console-setup
 cups-daemon
 netfilter-persistent
 iptables-persistent
 rsyslog
 binfmt-support
 x11-common
 libxss1:armhf
 libtk8.6:armhf
 tk8.6-blt2.5
 blt
 cups-core-drivers
 cups
 dphys-swapfile
 xfonts-utils
 gsfonts-x11
 python-tk
 idle-python2.7
 jarwrapper
 libice6:armhf
 libsm6:armhf
 libxt6:armhf
 libxmu6:armhf
 libxaw7:armhf
 libxtst6:armhf
 x11-utils
 libatk-wrapper-java
 libaudio2:armhf
 libbonoboui2-0:armhf
 libgtkglext1:armhf
 x11-xkb-utils
 libxklavier16:armhf
 liblightdm-gobject-1-0:armhf
 sat4j
 xserver-common
 tightvncserver
 x2x
 xfonts-100dpi
 xfonts-base
 xinit
 fake-hwclock
 triggerhappy

My sources.list:

deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi

#deb http://ftp.de.debian.org/debian stretch-backports main

#deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main 
#deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main

#deb http://archive.ubuntu.com/ubuntu/ bionic universe
#deb http://archive.ubuntu.com/ubuntu/ bionic-updates universe
#deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

output of uname -a:

Linux raspberrypi 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux

I've tried the commands from this post but it did not help.

  • It sounds like either you thought you could use buster sources without upgrading, or you thought you were upgrading (but did not follow the right sequence of commands). That is unfortunate... – goldilocks Oct 19 at 14:13
  • @goldilocks How can I fix this? – dan1st Oct 19 at 14:15
  • 1
    I don't know if you can, and -- eek -- I just noticed the base system was jessie (v8), not stretch (v9), meaning you tried to skip straight to v10. This was a very bad idea. You might want to clarify in the question what you thought you would accomplish by doing this; if there is a fix that information might be relevant. – goldilocks Oct 19 at 14:20
  • 2
    You could try apt-get -s install $(apt-history rollback | tr '\n' ' '). Then remove the buster sources from your apt-sources and do a sudo apt-get update again and if your are irish or have the luck of the irish it might work. If you managed the rollback I would suggest to use sdkman to install java. I dont know if this works on a raspbian but this link uses sdkman to install grails on as raspi (grails needs groovy and groovy needs java): recursive.codes/blog/post/7 – Peter Paul Kiefer Oct 19 at 15:42
  • 2
    What PeterPaulKiefer suggested I would only do on a cloned SD Card so you do not risk to completely destroy your installation. – Ingo Oct 19 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.