0

I am trying to flash the latest Raspbian image to a microSD card in a USB adapter using the balenaEtcher software on a Windows 10 Pro system on a Lenovo Thinkpad. Raspbian has two partitions, a FAT32 boot partition and an ext4 data partition.

The fine people at Balena helped me discover that Windows (or something) is creating new System Volume Information folder containing IndexerVolumeGuid and WPSettings.dat files on the FAT32 partition. Since these files are not in the image I'm flashing, the image and microSD checksums do not match and the operation is marked as failed.

I have read this question which addresses "How to prevent creation of “System Volume Information” folder in Windows 10 for USB flash drives?" Following those steps did prevent creation of the extraneous directory and files. The downside is that I believe new files on the system drive will no longer be indexed for searching.

Here's the question. On the same computer, and before following the steps in the question linked above, I could flash older versions of Raspbian without the creation of that extraneous directory. So, something in the boot partition of the 2019-09-26 Raspbian is triggering Windows to create that directory and files. I have extracted the boot partition from a version of Raspbian (2019-07-10) that works without the above changes and the one that fails unless the changes are installed. I've compared them with Meld, but but I don't see differences that would trigger Windows' indexer. How can I figure out what it is different about the 2019-09-26 Raspbian and make it stop without going through the steps at the link?

migrated from superuser.com Oct 19 at 17:46

This question came from our site for computer enthusiasts and power users.

  • How have you narrowed the problem down to the Raspbian image and not a recent Windows 10 update or a change in the way that Balena Etcher remounts the drive for checking? – Roger Jones Oct 21 at 12:30
  • 1
    @RogerJones Yes. It's the image. I have a library of older images. I can flash the 2019-07-10 image without trouble and without that SVI directory being created. Using the same computer, same Windows version, same Etcher version, and even the same SD card and adapter within the same hour, the 2019-09-26 image allows/causes the SVI directory to be created, and so causes a checksum error. – Bob Brown Oct 21 at 13:38
  • @RogerJones ... however, the 2019-09-26 image does work on other installations of Win10. something about that image interacts with something about my Win 10 installation in a way that other images do not. I hope and suspect that it will be easier to find the difference in the images than to find the one weird thing out of many in Win 10. (Sorry for the delay; I've been in class.) – Bob Brown Oct 21 at 19:43
  • No worries, sounds like you've got a handle on it anyway! I've no ideas on what could be causing this weirdness, sorry. – Roger Jones Oct 22 at 20:38
  • @RogerJones Nope, no handle. I know what is happening, but not why. – Bob Brown Oct 22 at 22:06
1

In order for Windows to index files on a drive, it must create the System Volume Information directory, assigning the drive a GUID, which it saves within that directory.

Windows will auto-create this directory upon attaching a removable drive with a Windows recognizable partition (FAT variants and NTFS).

  • To disable, set HKLM\SOFTWARE\Policies\Microsoft\Windows\DisableRemovableDriveIndexing to 1

    reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows\Windows Search" /v DisableRemovableDriveIndexing /t REG_DWORD /d 1
    
  • To manually add drives you want indexed:

    • CLI:

      # Add Drive D:
        windowssearch.exe index add "D:"
      
      # Add directory:
        windowssearch.exe index add "D:\Directory\Path"
      
    • GUI:

      1. WinKey+R > Open: control.exe srchadmin.dll > OK
      2. Modify > Tick drive to be indexed > OK
        • This indexes a drive letter not the unique removable drive, so in order for this to work, the removable drive must be assigned the same drive letter each time it's connected.
      3. Advanced > Rebuild
        • This will take several hours to complete a rebuild of the Index
1

If I understood correctly, you could disable it only on removable drives:

  1. open Local Group Policy Editor

    • goto: Computer Configuration -> Administrative Templates -> Windows Components -> Search

    • enable the following entry: Do not allow locations on removable drives to be added to libraries

  2. open the Registry Editor

    • goto: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsSearch

    • change the value for DisableRemovableDriveIndexing to 1

There are a few guides on the net as well, e.g. see here

  • Thank you; I didn't know about "DisableRemovableDriveIndexing" so I'll give that a try. I'd really like to figure out what's pathological about the 2019-09-26 Raspbian that causes this when earlier versions do not. – Bob Brown Oct 19 at 12:09
  • Sadly, that didn't work. With those changes in place, I can flash older versions of Raspbian, but trying to flash 2019-09-26 still creates the SVI directory. I think there must be something weird about the image itself. – Bob Brown Oct 19 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.